Download it now!
Bug 123793 - Can't step with keyboard to/between favorite special characters on group button
Summary: Can't step with keyboard to/between favorite special characters on group button
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Jim Raykowski
URL:
Whiteboard: target:6.3.0 target:6.2.5
Keywords: accessibility, bibisected, bisected, regression
Depends on:
Blocks: a11y Special-Character
  Show dependency treegraph
 
Reported: 2019-03-01 19:45 UTC by Aron Budea
Modified: 2019-06-11 10:24 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2019-03-01 19:45:33 UTC
- Start Writer.
- Open Insert Special Characters group button, by default the button "More Characters" is selected.
- Still on the button, try to move to any of the favorites using keyboard (not sure which should work: Tab/Shift-Tab, arrow keys or both).

=> Focus doesn't change.

Observed using LO 6.2.0.3 / Ubuntu 18.04.

In 6.0.0.3 the group button has to be added via Tools -> Customize, and the focus is on the first favorite. It's possible to cycle through the favorites and the button using Tab, and insert with space/enter key. Though focus is only shown on the first favorite (and only the first time), and on the button.

=> regression
Comment 1 Aron Budea 2019-03-01 19:46:09 UTC
Also seen by buovjaga.
Comment 2 Aron Budea 2019-03-01 20:31:03 UTC
This bug was indirectly caused by the following commit, but the "<property name="can_focus">False</property>" entries were added in the other commit listed second.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=3014e5f362c77c546452d45fcde96fcbae27235e
author		Caolán McNamara <caolanm@redhat.com>	2018-04-29 21:15:22 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2018-04-30 11:41:54 +0200

"hook up can-focus to ability to tab into the widget"

https://cgit.freedesktop.org/libreoffice/core/commit/?id=07cd70c86c8919107ef02dc12ea23ae8d72d5a1a
author		Yousuf Philips <philipz85@hotmail.com>	2017-10-23 18:42:38 +0400
committer	Yousuf Philips <philipz85@hotmail.com>	2017-10-25 02:12:14 +0200

"tdf#112430 improve popup of special character group button"
Comment 3 Aron Budea 2019-03-01 22:39:25 UTC
Fixing this is really easy, just need to change those "can_focus"  properties, but that brings back bug 113352, and the current state seems better to me (but if someone disagrees, feel free to make the change).

I tried to make the button the default via various properties, didn't work, "has_focus" seemed really promising, but alas, no joy.
Comment 4 Peter Vágner 2019-03-20 20:06:46 UTC
The description mentions visual appearance when using the feature. When considering visual aspect it appears to be a minor issue.
However when also considering access with a screen reader it turns to be more serious, at least according to my initial testing.

Consider following steps:
* create a new empty document in writer.
* Press F6 key several times until the focus moves to the standard toolbar.
* On the standard toolbar use right key to navigate until you find a button called Symbol.
* When activating this button by pressing spacebar the group expands and the More characters button receives the focus. Using tab key or arrow keys to navigate causes orca to report nothing.
* When activating the Symbols toolbar button by pressing the enter key, the group expands and More characters button is also activated showing the Special characters dialog the same way activating Insert -> Special characters... from the menu bar does. I can't say if this is a feature or a bug.

The fact screen reader users are getting no feetback when using standard navigation keyboard shortcuts while the More characters button is focused is definatelly a bug and I'd prefer to have that fixed even if it reintroduces bug 113352 since that feature is also accessible via the menu bar. In other words when comparing these two bugs this one has higher priority to me.
I haven't tested other builds so I can't say if no screen reader feetback is related to the appearance change described in previous comments.

Version: 6.2.1.2
Build ID: 6.2.1-1
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: en-US (en); UI-Language: en-US
Calc: threaded
Comment 5 Jim Raykowski 2019-05-06 01:43:46 UTC
Hi All,

Here is a patch that provides for keyboard tab navigation of the special characters popup window and also focuses on the 'More Characters...' button when the popup window is displayed.

https://gerrit.libreoffice.org/#/c/71834/
Comment 6 Buovjaga 2019-05-06 09:20:51 UTC
(In reply to Jim Raykowski from comment #5)
> Here is a patch that provides for keyboard tab navigation of the special
> characters popup window and also focuses on the 'More Characters...' button
> when the popup window is displayed.
> 
> https://gerrit.libreoffice.org/#/c/71834/

I confirm it works!

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 6323d7bc822fb8314aa0b9f6c570ab9b12e43517
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 6 May 2019
Comment 7 Commit Notification 2019-05-11 16:59:32 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/caa6de6c97b0c2fc82c6a2699a1e84b9d2eb9dbd%5E%21

tdf#123793 Add kb tab navigation to special chars popup window

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-05-19 17:24:24 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e8a1db012fbd185f52f38806bcac8bb9917c51c3%5E%21

tdf#123793 Follow up fix for kb nav of special chars popup

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2019-05-22 12:37:23 UTC
Verified in

Version: 6.3.0.0.alpha1+
Build ID: e7fb44b8c86b4dce1d4c6f15752cc3bf62b14888
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Jim Raykowski, thanks for fixing this issue!
Comment 10 Commit Notification 2019-05-23 08:09:17 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/cf4c1bcc2c309ce3dcf1fceda8133a9a8f6a9556%5E%21

tdf#123793 Add kb tab navigation to special chars popup window

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-06-11 10:24:17 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/57b609f2ac50e03e148477a8a403a70e6f4fd5e1%5E%21

tdf#123793 Follow up fix for kb nav of special chars popup

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.