Bug 123817 - Erratic CTRL+Home in Writer documents with Headers and HIDDEN Sections
Summary: Erratic CTRL+Home in Writer documents with Headers and HIDDEN Sections
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Section
  Show dependency treegraph
 
Reported: 2019-03-03 15:17 UTC by Gabriele
Modified: 2019-08-03 17:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Header, Hidden section CTRL+Home not working (10.07 KB, application/vnd.oasis.opendocument.text)
2019-03-03 15:19 UTC, Gabriele
Details
CTRL+Home with Header and Hidden Section not working (9.41 KB, application/vnd.oasis.opendocument.text)
2019-03-14 22:15 UTC, Gabriele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriele 2019-03-03 15:17:12 UTC
Description:
CTRL+Home works like this:

    1. Cursor INSIDE a section: on pressing CTRL+Home ONCE the cursor goes to the beginning of the Section, not the Document (likewise CTRL+End goes to the end of the Section, not the end of the doc).
    2. Cursor INSIDE a section: on pressing CTRL+Home TWICE the cursor does the same, while CTRL+End TWICE sends the cursor to the end of the doc.
    3. Cursor OUTSIDE a section: on pressing CTRL+Home ONCE (or more) the cursor  goes to the end of the paragraph (CTRL+End correctly goes to the end of the doc).
    4. If the document uses Headers and Hidden sections at the beginning, CTRL+Home is erratic.


Steps to Reproduce:
1.Create Header
2.Insert Hidden Section at the very beginning of the document
3.Add text out of section as well as further sections

Actual Results:
There is a Hidden Section at the very beginning of the document, above this line.
The document has a Header. No Header documents seem to work OK...
This text is OUTSIDE Sections. CTRL+Home does not work from here.
___________________________________________________________________
This is Section One
CTRL+Home works like this:
    1. Cursor INSIDE a section: on pressing CTRL+Home ONCE the cursor goes to the beginning of the Section, not the Document (likewise CTRL+End goes to the end of the Section, not the end of the doc).
    2. Cursor INSIDE a section: on pressing CTRL+Home TWICE the cursor does the same, while CTRL+End TWICE sends the cursor to the end of the doc.
    3. Cursor OUTSIDE a section: on pressing CTRL+Home ONCE (or more) the cursor  goes to the end of the paragraph (CTRL+End correctly goes to the end of the doc).
    4. If the document uses Headers and Hidden sections at the beginning, CTRL+Home is erratic.
End of Section One
___________________________________________________________________

Text OUTSIDE Sections

___________________________________________________________________
This is Section Two
CTRL+Home works within this Section...
End of Section Two
___________________________________________________________________

Text OUTSIDE Sections.

___________________________________________________________________
This is Section Three
CTRL+Home works within this Section...
End of Section Three
___________________________________________________________________

Text OUTSIDE Sections
Put cursor here and try CRTL+Home.

Expected Results:
CTRL+Home should go to the top of the Document. CTRL+End to the bottom.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.1.5.2 (x64)
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: en-GB (it_IT); Calc: group threaded
Comment 1 Gabriele 2019-03-03 15:19:18 UTC
Created attachment 149695 [details]
Header, Hidden section CTRL+Home not working
Comment 2 Xisco Faulí 2019-03-14 21:02:05 UTC
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 3 Gabriele 2019-03-14 22:15:22 UTC
Created attachment 149981 [details]
CTRL+Home with Header and Hidden Section not working
Comment 4 Gabriele 2019-03-14 22:16:08 UTC
Still not working for me with version: 6.2.1.2 (x64)
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-GB (it_IT); UI-Language: en-GB
Calc: threaded
Comment 5 Buovjaga 2019-08-03 17:35:03 UTC
Confirmed with 3.3.0 already (Win 10)

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: 4bd1b38633d6cb288eb559afc0ac6b961538ae60
CPU threads: 8; OS: Linux 5.2; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 24 July 2019