Bug Hunting Session
Bug 123824 - Truncated data in Assign Columns dialog in split-mode hsqldb
Summary: Truncated data in Assign Columns dialog in split-mode hsqldb
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2019-03-04 00:16 UTC by Fabiano Freitas
Modified: 2019-09-09 23:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Assign Columns dialog (16.29 KB, image/png)
2019-03-04 00:16 UTC, Fabiano Freitas
Details
Calc table sample (7.39 KB, image/png)
2019-03-04 00:19 UTC, Fabiano Freitas
Details
Example-database and Calc file to try the import of data (9.29 KB, application/zip)
2019-03-04 08:13 UTC, Robert Großkopf
Details
Assign columns (11.16 KB, image/png)
2019-03-04 17:57 UTC, Fabiano Freitas
Details
How it looks for me in master (15.61 KB, image/png)
2019-08-09 11:30 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabiano Freitas 2019-03-04 00:16:26 UTC
Created attachment 149696 [details]
Assign Columns dialog

I usually populate my HSQLDB table by copying data from a Calc table. I do so by selecting Paste > Append data. I haven't had any problems with this until updating the LibreOffice to the latest version (6.2.0.3).

In Assign Columns dialog, the field values from source table show up truncated. The assignment works fine, though.
Comment 1 Fabiano Freitas 2019-03-04 00:19:43 UTC
Created attachment 149697 [details]
Calc table sample
Comment 2 Fabiano Freitas 2019-03-04 02:53:30 UTC
In previous versions of LibreOffice, it would have showed this:

Source table:

600
FOOBAR FOOBAR FOOBAR FOOBAR
1,5
73261900
Comment 3 Robert Großkopf 2019-03-04 08:13:58 UTC
Created attachment 149699 [details]
Example-database and Calc file to try the import of data

Can't confirm the buggy behaviour with LO 6.2.0.3 on OpenSUSE 15 64bit rpm Linux. The values of the first row are shown in the import-wizard here.
Comment 4 ribotb 2019-03-04 13:09:51 UTC
With database of Robert, If I accept to migrate  to Firebird embedded I encounter the problem described in bug 123591 : "Seems Base/Firebird doesn't recognize the decimalseparator from the Calc-import-file". 

If I don't accept to migrate, I obtain this error message when I try to open database : 
Impossible d'établir la connexion à la source de données "import".
file input/output error: C:\Users\bernard\Desktop\import.odb.log

Bernard
Comment 5 Robert Großkopf 2019-03-04 14:56:11 UTC
(In reply to ribotb from comment #4)
> With database of Robert, If I accept to migrate  to Firebird embedded I
> encounter the problem described in bug 123591 : "Seems Base/Firebird doesn't
> recognize the decimalseparator from the Calc-import-file". 

Please don't mix this with Firebird bugs. It is reported as HSQLDB bug. The migration dialogue would only appear with experimental functions switched to 'on'.

Set this off and try it with the original database again. You have to mark the content of Calc table, copy this and then directly insert this content to Base table.
Comment 6 Fabiano Freitas 2019-03-04 16:23:35 UTC
Tried the example (HSQLDB embedded database) provided by Robert and it works OK.

However, I am using 'split' database mode (sorry for not mentioning that above). I will create a new example database and see if the problem persists.

I'll report back ASAP.
Comment 7 Fabiano Freitas 2019-03-04 17:57:25 UTC
Created attachment 149722 [details]
Assign columns

Yep.. the problem appears to be related to the split database mode.

When using it, the values of the first row truncate and/or show wrongly.

Using an embedded HSQLDB database, the issue won't occur.
Comment 8 ribotb 2019-03-04 18:01:58 UTC
(In reply to Robert Großkopf from comment #5)
> (In reply to ribotb from comment #4)
> > With database of Robert, If I accept to migrate  to Firebird embedded I
> > encounter the problem described in bug 123591 : "Seems Base/Firebird doesn't
> > recognize the decimalseparator from the Calc-import-file". 
> 
> Please don't mix this with Firebird bugs. It is reported as HSQLDB bug. The
> migration dialogue would only appear with experimental functions switched to
> 'on'.
> 

Sorry!
Comment 9 Alex Thurgood 2019-03-13 15:05:27 UTC
@lnwalker : the problem is that there aren't many people in Base-QA using split-mode hsqldb - I dont' have any on macOS because pointing to a separate hsqldb.jar has had various nefarious consequences in the past including not being able to open normal previously created embedded hsqldb files, to the point where I no longer test such a db configuration.
Comment 10 Xisco Faulí 2019-07-08 16:01:27 UTC
@Drew, any chance you could bisect this issue ?
Comment 11 Xisco Faulí 2019-08-09 11:28:57 UTC
I can't reproduce it in

Version: 6.4.0.0.alpha0+
Build ID: d4a70ecf61b016a32caef015eea127d13b357cf7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Dear Reporter,
Could you please paste the info from Help - about LibreOffice ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided
Comment 12 Xisco Faulí 2019-08-09 11:30:37 UTC
Created attachment 153261 [details]
How it looks for me in master
Comment 13 Fabiano Freitas 2019-08-29 04:33:12 UTC
OK. I've done further tests and can confirm that the problem is resolved. BUT, I had to recreate a new database file (.odb) and start using it. With the old database file (.odb) that issue reported happened all the time. I don't know why and if that makes sense, since I always worked on that file and saved it regularly.

Remembering that I'm using a split database.


I've run into some crashes with Base, but I am going to report that in another thread.


Using:

Version: 6.3.0.4 (x86)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: pt-BR (pt_BR); UI-Language: en-US
Calc: threaded
Comment 14 Xisco Faulí 2019-09-09 23:37:36 UTC
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.