Bug 123839 - window frame too wide - mouse doesn't touch scrollbar
Summary: window frame too wide - mouse doesn't touch scrollbar
Status: CLOSED MOVED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-04 13:05 UTC by gnomek
Modified: 2021-09-22 16:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gnomek 2019-03-04 13:05:26 UTC
I'd like to be able to apply qtcurve properly.

I tried 

GTK2_RC_FILES=/usr/share/themes/QtCurve/gtk-2.0/gtkrc libreoffice --writer

but it doesn't do anything.

I start this way another gtk program: cherrytree with success, I mean it has qtcurve look.

It would be great if something like this was possible in:
/etc/profile.d/libreoffice-still.sh

export SAL_USE_VCLPLUGIN=qtcurve

Why I want this? Because qtcurve has lots of great settings. For example I can easily set scrollbar width. 

I use Linux with Plasma 5 desktop and breeze-dark theme and scrollbar is very narrow and it doesn't touch window edge. 
https://i.imgur.com/RwQyrtG.png

With qtcurve I would be able to solve it quickly and independently from KDE/Plasma or gtk themes limitations.


Operating System: Manjaro Linux 
KDE Plasma Version: 5.15.1
KDE Frameworks Version: 5.55.0
Qt Version: 5.12.1
Kernel Version: 4.20.11-1-MANJARO
OS Type: 64-bit
Comment 1 gnomek 2019-03-13 09:38:16 UTC
I would like to point out that for me it is more usability problem than "good look" problem (although I would love to be able to apply qtcurve to LO).

The problem that mouse can't touch scrollbar is caused by fat window frame, or maybe it is a problem of specific vcl - gtk or gtk3-kde5 or qt5. But I changed scrollbar width as showed here
https://forums.opensuse.org/showthread.php/533904-KDE-themes-and-widgits-and-whatnots-Scroll-bar-width-in-Firefox-and-LibreOffice

and mouse still doesn't touch scrollbar.

Feel free to assign this to appropriate category of bugs. Tell me if I need to fill separate bug report for window edge or theme related bug. I haven't done this yet because I don't know what is the specific cause of the problem.
Comment 2 gnomek 2019-03-14 09:09:50 UTC
I renamed the bug because in LO 6.2 qtcurve is applied with 
export SAL_USE_VCLPLUGIN=kde

So the problem is with Breeze-dark theme on Plasma 5, with LO 6.1.5.2
Build ID: 6.1.5-2, VCL: gtk3_kde5;
Comment 3 gnomek 2019-03-17 10:22:27 UTC
I found out that proper place to report it is breeze-gtk on kde bugs.

https://bugs.kde.org/show_bug.cgi?id=357314
Comment 4 Xisco Faulí 2019-04-17 15:33:01 UTC
(In reply to gnomek from comment #3)
> I found out that proper place to report it is breeze-gtk on kde bugs.
> 
> https://bugs.kde.org/show_bug.cgi?id=357314

Thanks.
Closing as RESOLVED MOVED
Comment 5 StevenMaxwell 2019-05-17 12:36:10 UTC Comment hidden (spam)
Comment 6 Jeniifer 2020-01-10 04:39:24 UTC Comment hidden (spam)
Comment 7 Freya Collins 2020-01-16 08:20:09 UTC Comment hidden (spam)
Comment 8 JohnForster 2020-02-14 18:05:44 UTC Comment hidden (spam)
Comment 9 Sophie Williams 2020-07-29 10:27:55 UTC Comment hidden (spam)