Download it now!
Bug 123862 - File locking has no benefits at all
Summary: File locking has no benefits at all
Status: RESOLVED DUPLICATE of bug 41442
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-05 09:23 UTC by Szasz-Fabian Jozsef
Modified: 2019-06-27 11:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Szasz-Fabian Jozsef 2019-03-05 09:23:54 UTC
Description:
I want to disable file locking forever. This feature has onlz annozances, and has no benefits at all.
- When working with files on cloud, the lock files are spamming the directory.
- When disconnecting from the drive (cloud, network, etc.) the lock file remains and prevents other users to open the document.
- The edited and then saved file cannot be renamed, moved, etc. Other software has no problems at all with this.

Steps to Reproduce:
1. Edit a file
2. Save the file
3. Go to exporer and try to rename, move

Actual Results:
The file is locked

Expected Results:
Don't lock the file. Let the user do whatever wants with the file. Like other applications (Photoshop, etc.)


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 Usama 2019-05-21 16:06:54 UTC
Hello Szasz-Fabian Jozsef,
Thank you for reporting this bug. I find that it could be a duplicate of this bug as you are asking for something similar

Control File Locking from Options
https://bugs.documentfoundation.org/show_bug.cgi?id=41442
Comment 2 Xisco Faulí 2019-06-27 11:53:08 UTC
(In reply to Usama from comment #1)
> Hello Szasz-Fabian Jozsef,
> Thank you for reporting this bug. I find that it could be a duplicate of
> this bug as you are asking for something similar
> 
> Control File Locking from Options
> https://bugs.documentfoundation.org/show_bug.cgi?id=41442

it makes sense... Closing as a Duplicate

*** This bug has been marked as a duplicate of bug 41442 ***