Bug Hunting Session
Bug 123968 - Input Field (Functions): direct editing is still used, not pop-up dialog
Summary: Input Field (Functions): direct editing is still used, not pop-up dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks: Fields
  Show dependency treegraph
 
Reported: 2019-03-09 20:50 UTC by Mike Kaganski
Modified: 2019-04-23 09:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2019-03-09 20:50:34 UTC
After fixing tdf#79877 [1], the Input Field from Variables tab is now edited using a pop-up dialog, instead of previous in-place edit method. But we have more than one Input Field :-) - and the other one is on Functions tab of Fields dialog.

The latter still uses in-place edit method, as of Version: 6.2.2.1 (x64)
Build ID: fcd633fb1bf21b0a99c9acb3ad6e526437947b01
CPU threads: 12; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: CL

Should it be synchronized with the Input Field from Variables tab for consistency?

[1] https://git.libreoffice.org/core/+/7d5245848c28f5786258476cd7aa2a4523645de3
Comment 1 Oliver Brinzing 2019-03-10 09:35:29 UTC
(In reply to Mike Kaganski from comment #0)
> After fixing tdf#79877 [1], the Input Field from Variables tab is now edited
> using a pop-up dialog, instead of previous in-place edit method. But we have
> more than one Input Field :-) - and the other one is on Functions tab of
> Fields dialog.

I can confirm this.
Comment 2 Samuel Mehrbrodt (CIB) 2019-03-11 07:04:35 UTC
(In reply to Mike Kaganski from comment #0)
> After fixing tdf#79877 [1], the Input Field from Variables tab is now edited
> using a pop-up dialog, instead of previous in-place edit method. But we have
> more than one Input Field :-) - and the other one is on Functions tab of
> Fields dialog.

Hm I see no difference to the other input field. Single click activates inline editing mode while double click opens the dialog to edit the value.

Am I missing something? Can you maybe create a test document with an example?
Comment 3 Mike Kaganski 2019-03-11 07:10:19 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #2)
> Hm I see no difference to the other input field. Single click activates
> inline editing mode while double click opens the dialog to edit the value.

Oh! For me both on Windows and on Ubuntu, with all recent versions, including master, single-click on Input Field from Variables tab activates the same dialog - could that be some overlooked unintended consequence specific for the field on Variables tab then? Or did I misunderstand something - possibly it's the other field was modified to have two edit modes, while this one still only allows one using dialog?
Comment 4 Samuel Mehrbrodt (CIB) 2019-03-11 07:23:44 UTC
Ok so there is a difference between the input field from the Variables tab and the Functions tab.
Bug 79877 implemented the new behavior for fields from the Functions tab.

The same should be done for fields from the Variables tab. Single click should allow in-place editing while double click should open the input dialog.
The field properties dialog should be reachable via context menu.
Comment 5 Commit Notification 2019-04-08 14:09:32 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/742baabbe4d077e1ba913a7989300908f4637ac7%5E%21

tdf#123968 sw: use inline editing for input fields for variables

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-04-23 09:02:29 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/053b1417137b0cdec4e4fed7ae0c57cf67ff2698%5E%21

tdf#123968 Test that imported field is editable

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.