Bug 123988 - "Strange" interface in recent versions (6.2+)
Summary: "Strange" interface in recent versions (6.2+)
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: UI-Theming
  Show dependency treegraph
 
Reported: 2019-03-10 23:25 UTC by Alex
Modified: 2019-08-17 16:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Interface (83.47 KB, image/png)
2019-03-10 23:40 UTC, Alex
Details
Version 6.2.3 (93.37 KB, image/png)
2019-04-19 20:04 UTC, Alex
Details
The background color was manual adjustment. The toolbar follows white ... As well as the highlight (in blue) of the tools. In version 6.1 (earlier attachments), this does not occur. (48.82 KB, image/png)
2019-05-19 22:47 UTC, Alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2019-03-10 23:25:07 UTC
Description:
Since the release of version 6.2 ... The application interface (in AppImage) is totally white - being aggressive to the eyes; as well as displaying highlights in dark blue on the toolbar.

In the old version, 6.1.5.2 does not occur. And the interface is a lot nicer.

Steps to Reproduce:
Open the application.

Actual Results:
A poorly finished interface is displayed (all white and with blue markings - you can not see what is selected).

Expected Results:
Adopt the same color style as version 6.1.5.


Reproducible: Always


User Profile Reset: No



Additional Info:
I have not found how to post screenshots here; so I'm posting a link from my Google Drive:

https://drive.google.com/drive/folders/1TGx2cbEX60wuBaaN_BbAU7hT8dFmfNzK?usp=sharing

The new interface (6.2) in AppImage is not good.
Comment 1 Alex 2019-03-10 23:40:26 UTC
Created attachment 149870 [details]
Interface
Comment 2 Xisco Faulí 2019-03-13 21:25:20 UTC
Thank you for reporting the bug. To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 3 Alex 2019-03-14 14:52:52 UTC
(In reply to Xisco Faulí from comment #2)
> Thank you for reporting the bug. To be certain the reported issue is not
> related to corruption in the user profile, could you please reset your
> Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
> re-test?
> 
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the issue is still present

This problem is native to recent versions.
Comment 4 Alex 2019-04-19 20:02:46 UTC
The problem persists in the new version 6.2.3.
Comment 5 Alex 2019-04-19 20:04:03 UTC
Created attachment 150885 [details]
Version 6.2.3
Comment 6 Xisco Faulí 2019-05-16 09:41:50 UTC
You can't confirm your own bugs. Moving it back to UNCONFIRMED until someone
else confirms it.
Comment 7 raal 2019-05-16 21:25:48 UTC
Did you tried profile reset? Or start in safe mode (Help-> Restart in safe mode). Application colors are customizable in Tools -> Options-> Libreoffice-> Application colors
Comment 8 Alex 2019-05-19 21:33:06 UTC
(In reply to Xisco Faulí from comment #2)
> Thank you for reporting the bug. To be certain the reported issue is not
> related to corruption in the user profile, could you please reset your
> Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
> re-test?
> 
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the issue is still present

But you did not ask to do the tests; and leave it as "unconfirmed" if the problems persist? I did not understand.
Comment 9 Alex 2019-05-19 22:42:53 UTC
(In reply to raal from comment #7)
> Did you tried profile reset? Or start in safe mode (Help-> Restart in safe
> mode). Application colors are customizable in Tools -> Options->
> Libreoffice-> Application colors

There is no change in Safe Mode. The design stays the same.

I recently tested ClearOS (from Intel) and did not see interface problems (version 6.2). It seems that some complement is missing from Deepin.

As I use the AppImage version, the problem still persists.
Comment 10 Alex 2019-05-19 22:47:33 UTC
Created attachment 151521 [details]
The background color was manual adjustment. The toolbar follows white ... As well as the highlight (in blue) of the tools.  In version 6.1 (earlier attachments), this does not occur.
Comment 11 Buovjaga 2019-08-17 16:02:29 UTC
Deepin uses its own desktop environment based on Qt: https://en.wikipedia.org/wiki/Deepin
As you are using the gtk3 UI of LibreOffice, it is picking up whatever gtk theme Deepin desktop settings have defined. Please try finding out, how to configure the gtk theme used in Deepin.