Bug Hunting Session
Bug 124019 - Make table styles extensionizable
Summary: Make table styles extensionizable
Status: RESOLVED DUPLICATE of bug 105933
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables-Style
  Show dependency treegraph
 
Reported: 2019-03-12 10:31 UTC by Nicolas Göddel
Modified: 2019-03-13 10:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Göddel 2019-03-12 10:31:16 UTC
Description:
It seems there is no way to create a new table style out of the box. One can create new paragraph, character, frame, page and list styles but when I right click in the table style side panel I simply get an empty popup menu. I want to create a new table style here to assign it to future tables in my document. Or I want to duplicate or change existing styles.

There is this AutoFormat feature for tables where I can add a new AutoFormat which then also appears in the table styles side panel. But after adding this new AutoFormat I can not change anything. I don't understand this feature. There seems to be no explanation for it. I can delete it in the side panel but funny enough it still exists in the AutoFormat dialog window and vice versa: If I delete it in the AutoFormat dialog it still exists in the table styles list. So it seems these are two different things somehow linked together.

Steps to Reproduce:
None

Actual Results:
None

Expected Results:
None


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.5.2 (x64)
Build-ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU-Threads: 4; BS: Windows 6.1; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group threaded
Comment 1 Heiko Tietze 2019-03-13 10:02:06 UTC
The workaround is to use the legacy Table > AutoFormat Styles... dialog that has only partially superseded by the new workflow. The request is filed in bug 105933.

But besides the editing capabilities it would be nice to share table styles via extensions. And as far as I can see we haven't a ticket on that.
Comment 2 Heiko Tietze 2019-03-13 10:04:52 UTC
Sorry, it's a bit rude to hijack your ticket. I file a new request about the extension thing (bug 124046) and close this as duplicate.

Thanks for reporting!

*** This bug has been marked as a duplicate of bug 105933 ***