Bug 124051 - DATE problem when changed to firebird
Summary: DATE problem when changed to firebird
Status: RESOLVED DUPLICATE of bug 117732
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 124050 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-03-13 11:19 UTC by Tim
Modified: 2019-03-13 12:33 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim 2019-03-13 11:19:10 UTC
Description:
Format disappears, and most important: it subtracted one day to each date!

Actual Results:
All dates are one day less than what I had in the data base!

Expected Results:
No change of date.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Tim 2019-03-13 11:20:54 UTC
It could be after User Profile Reset, but don' know, as even I don't remember if I made such reset.
Comment 2 Alex Thurgood 2019-03-13 11:55:33 UTC
@Tim : sorry, we need more information than that.

Please provide detailed information on how to reproduce the issue.

Is this :

- a migration problem caused by the migration tool from embedded hsqldb to embedded firebird ;

- a problem that you encounter when adding or changing data in a firebird table (direct data edit mode) ;

- a problem that you encounter when adding or changing data in a firebird database via a form ?

- if the problem is with a form, what are the form controls you are using ?
Comment 3 Tim 2019-03-13 12:00:48 UTC
(In reply to Alex Thurgood from comment #2)
> @Tim : sorry, we need more information than that.
> 
> Please provide detailed information on how to reproduce the issue.
> 
> Is this :
> 
> - a migration problem caused by the migration tool from embedded hsqldb to
> embedded firebird ;
> 
> - a problem that you encounter when adding or changing data in a firebird
> table (direct data edit mode) ;
> 
> - a problem that you encounter when adding or changing data in a firebird
> database via a form ?
> 
> - if the problem is with a form, what are the form controls you are using ?


It's a problem caused by the migration from embedded hsqldb to embedded firebird. I discovered in the Table with DATES DD/MM/YYYY it subtracted one day. I still can open the database I had before migration and DATES are correct.
Comment 4 Alex Thurgood 2019-03-13 12:01:39 UTC
@Tim: thanks !

additionally, please provide the setting under LibreOffice > Preferences > Calc > Calculations, which date setting have you chosen (30/12/1899; 01/01/1900; 01/01/1904)? 

And your time zone, OS system locale, and LO UI locale
Comment 5 Alex Thurgood 2019-03-13 12:03:44 UTC
Duplicate of bug 117732

See:
https://bugs.documentfoundation.org/show_bug.cgi?id=117732#c3

*** This bug has been marked as a duplicate of bug 117732 ***
Comment 6 Tim 2019-03-13 12:09:27 UTC
(In reply to Alex Thurgood from comment #4)
> @Tim: thanks !
> 
> additionally, please provide the setting under LibreOffice > Preferences >
> Calc > Calculations, which date setting have you chosen (30/12/1899;
> 01/01/1900; 01/01/1904)? 
> 
> And your time zone, OS system locale, and LO UI locale


Can't finde Calc > Calculations under Preferences

I'm in Spain: Central Europe
Comment 7 Alex Thurgood 2019-03-13 12:15:31 UTC
(In reply to Tim from comment #6)

 
> I'm in Spain: Central Europe

Thanks, I don't need any further information, this has been marked as a duplicate of known bug 117732, which hasn't been fixed (at least not for dates). The problems are linked to the fact that hsqldb stores dates as timezone dependent values, whereas the current firebird engine version we use doesn't know anything about such values automatically, and the migration code doesn't therefore deal with them correctly.
Comment 8 Tim 2019-03-13 12:18:48 UTC
(In reply to Alex Thurgood from comment #7)
> (In reply to Tim from comment #6)
> 
>  
> > I'm in Spain: Central Europe
> 
> Thanks, I don't need any further information, this has been marked as a
> duplicate of known bug 117732, which hasn't been fixed (at least not for
> dates). The problems are linked to the fact that hsqldb stores dates as
> timezone dependent values, whereas the current firebird engine version we
> use doesn't know anything about such values automatically, and the migration
> code doesn't therefore deal with them correctly.

OK Thanks. I'll change the data manually! Some hundreds!
Comment 9 Julien Nabet 2019-03-13 12:33:50 UTC
*** Bug 124050 has been marked as a duplicate of this bug. ***