Bug Hunting Session
Bug 124144 - EDITING: Multiselect + Ctrl-C crashed Calc
Summary: EDITING: Multiselect + Ctrl-C crashed Calc
Status: RESOLVED DUPLICATE of bug 121949
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-18 09:18 UTC by Peer Sommerlund
Modified: 2019-03-20 17:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peer Sommerlund 2019-03-18 09:18:37 UTC
I selected 12 not-connected cells by holding down Ctrl, and clicking on the cells one at a time. When I then pressed Ctrl-C LibreOffice crashed.

Crash report a9992882-2773-410c-8686-420b9949d4f5



I restarted LibreOffice and tried again on a different tab in the same worksheet, and the same happened.

If I select cells that are only separated verticaly (A1,A3), Calc does not crash. 
If I select cells that are only separated horizontally(A1,C1), Calc does not crash

If I select cells in both cases (A1,A3,C1), the crash occurs.
If I select cells in both cases (A1,A3,C1,C3), the crash occurs.

Selecting A1,A3,A5 does not crash.
Comment 1 Oliver Brinzing 2019-03-18 17:58:26 UTC
(In reply to Peer Sommerlund from comment #0)
> I selected 12 not-connected cells by holding down Ctrl, and clicking on the
> cells one at a time. When I then pressed Ctrl-C LibreOffice crashed.
> If I select cells in both cases (A1,A3,C1,C3), the crash occurs.

I can't reproduce it in:

Version: 6.1.5.2 (x64)
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: 

Version: 6.2.2.1 (x64)
Build-ID: fcd633fb1bf21b0a99c9acb3ad6e526437947b01
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

In both cases i get an info message:
"This function cannot be used with multiple selections."

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

If the bug is still present, please attach a sample document, as this makes it easier for us to verify the bug. (Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 2 raal 2019-03-18 18:48:32 UTC
This is fixed in 6.2.2

*** This bug has been marked as a duplicate of bug 121949 ***