Download it now!
Bug 124167 - Changing text properties doesn't make presentation modified right away
Summary: Changing text properties doesn't make presentation modified right away
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Henry Castro
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks: ModifiedStatus
  Show dependency treegraph
 
Reported: 2019-03-18 14:40 UTC by Aron Budea
Modified: 2019-03-25 14:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencast (315.62 KB, video/mp4)
2019-03-21 18:10 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2019-03-18 14:40:06 UTC
- Open a presentation with text content.
- Change text properties for a piece of text (eg. make it bold or italic).

=> Presentation shows it isn't modified (state of save button doesn't change).

It only gets modified once you type something, or when you click outside the text box.

Observed using LO 6.3.0.0.alpha0+ (205e2d6c31b1861111b70a704516580761a75099) & 3.3.0 / Ubuntu 18.04.
Comment 1 Henry Castro 2019-03-21 14:28:07 UTC
Aron,

I cannot reproduce in Master branch
Comment 2 Xisco Faulí 2019-03-21 14:42:01 UTC
Yep, I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: 7c7a4675ad5d61add70dd073f680ea37012962ce
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

nor in

Versió: 6.1.4.2
ID de la construcció: 1:6.1.4-0ubuntu0.16.04.1~lo2
Fils de CPU: 4; SO: Linux 4.15; Renderitzador de la IU: per defecte; VCL: gtk3; 
Configuració local: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 3 Aron Budea 2019-03-21 18:10:21 UTC
Created attachment 150154 [details]
Screencast

Please see the attached screencast.

- The presentation starts as unmodified.
- After changing a piece of text to bold it's still unmodified. <= bug
- After clicking away from text box, it becomes modified.
- For reference, after reloading and typing in the text box, the presentation becomes modified right away, no need to click away.
Comment 4 Aron Budea 2019-03-21 18:13:13 UTC
The build is 6.3.0.0.alpha0+ (210ed60686009128bc772af6ba41650ad17d40e1) from two days ago, while I don't rule out the bug's become fixed in the past two days, I consider that unlikely, and for sure it's there in 6.1.4.2.
Comment 5 Henry Castro 2019-03-22 12:01:14 UTC
Aron,


Thanks, got it, I can reproduce in master, it is the shortcut Ctrl+B.

Working on it.
Comment 6 Henry Castro 2019-03-22 16:13:44 UTC
Aron,

https://gerrit.libreoffice.org/#/c/69564/

It should solve the problem, but first would you please verify?

Thanks
Henry
Comment 7 Aron Budea 2019-03-22 20:22:04 UTC
(In reply to Henry Castro from comment #6)
> https://gerrit.libreoffice.org/#/c/69564/
> 
> It should solve the problem, but first would you please verify?
With this patch, if I select a piece of text in the sample and apply attributes to it, the whole text gets it (eg. of the "11111" I select a single "1" and make it bold, the whole "11111" becomes bold). Before, only the selected text got the attribute change.
Comment 8 Commit Notification 2019-03-25 13:59:21 UTC
Henry Castro committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/dd8010c037a06763b3554739c01c9029988ad84f%5E%21

tdf#124167: Changing text properties doesn't make presentation...

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.