Bug 124207 - 3rd signature becomes invalid
Summary: 3rd signature becomes invalid
Status: RESOLVED DUPLICATE of bug 109371
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2019-03-19 13:52 UTC by wdehoog
Modified: 2019-03-20 13:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wdehoog 2019-03-19 13:52:37 UTC
When adding 3 signatures to a document the 3rd one becomes invalid.

Then when removing the 1st or the 2nd one the invalid 3rd one becomes the 2nd one and turns valid.
Comment 1 mulla.tasanim 2019-03-20 06:15:36 UTC
Hello

Thank you for reporting the bug. 
Unfortunately without clear steps to reproduce it, we cannot track down the origin of the problem. 
Please provide a clearer set of step-by-step instructions on how to reproduce the problem.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested information is provided.
Comment 2 wdehoog 2019-03-20 07:23:59 UTC
Hello,

Sorry. I thought I was clear.

With "When adding 3 signatures to a document" I mean three different people try to sign the same document with their Digitial Signature.

With "the 3rd one becomes invalid." I mean when the 3rd person signs the document it's added signature is invalid. Invalid in the sense that the icon in the list of signatures becomes a yellow icon and the signature bar above the document becomes red and says that the document contains an invalid signature.


With "when removing the 1st or the 2nd one the invalid 3rd one becomes the 2nd one and turns valid." I mean that removing the 1st or the 2nd signature causes the 3rd signature to become the 2nd one (3-1=2) and then it becomes valid again: no yellow icon and the signature bar becomes blue.

So for the 3rd signature it seems the postion makes it invalid not it's actual content.

I do hope I added the information you needed. Please ask if you have any more questions.
Comment 3 Dieter 2019-03-20 13:34:30 UTC

*** This bug has been marked as a duplicate of bug 109371 ***