Bug 124236 - EDITING: Cannot correct an incorrect hyphenation point
Summary: EDITING: Cannot correct an incorrect hyphenation point
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Hyphenation
  Show dependency treegraph
 
Reported: 2019-03-21 08:23 UTC by Luke Kendall
Modified: 2019-08-25 11:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screen snapshot of the dialogue (39.86 KB, image/png)
2019-03-21 08:23 UTC, Luke Kendall
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke Kendall 2019-03-21 08:23:43 UTC
Created attachment 150139 [details]
Screen snapshot of the dialogue

The instructions for altering (editing) the hyphenation point, provided at https://help.libreoffice.org/Writer/Hyphenation don't work, at least for the word "Handover".
The hyphenation point is defined to be Han-dover instead of Hand-over, and the hyphenation point cannot be changed because the left and right arrow buttons below the box in the Hyphenation dialogue are greyed out.

The help text says:
"To change the hyphenation of the displayed word, click the left or right arrow below the word, and then click Hyphenate. The left and right buttons are enabled for words with multiple hyphenation points."

Does this mean if the word has only a single hyphenation point, it can't be changed?  If so, errors in hyphenation can't always be corrected.
Comment 1 Usama 2019-05-21 16:30:01 UTC
Hello Luke,
Thank you for reporting this issue. I've checked how "handover" is hyphenated in some online tools [1] which is based on a popular spell checking library, I found they do similar to LibreOffice. If you think you should be able to edit that I would consider setting this request as feature request. 

You may want to join QA team channel[2] @freenode to discuss it further.

----------
1. Hyphenate it! https://www.ushuaia.pl/hyphen/?ln=en
2. #libreoffice-qa @freenode https://irc.documentfoundation.org/?settings=#libreoffice-qa
Comment 2 Luke Kendall 2019-05-22 08:17:25 UTC
I'm looking into this.
I see what you mean.
I'm trying to find references for my ancient teachings of the principles of where to hyphenate words. I haven't found much on the choice of possible hyphenation points (the things built in at the lowest level of TeX's generally fantastic algorithm).
My recollection was that one possible insertion point was always allowed when the word was formed of compound words (like news and paper or hand and over).
But I do note that Knuth himself here remarks that TeX does indeed sometimes get it wrong:
https://www.tug.org/TUGboat/tb04-2/tb08knut.pdf
so the ability to correct it would indeed be a useful feature.
Comment 3 Luke Kendall 2019-05-23 09:09:59 UTC
I just rechecked my screenshot.

I'm happy enough to submit a feature request instead, but I hesitate because it still looks like a bug to me.

My logic is that:
1. the dialog shows the hyphenation point selected.
2. There is a Remove button (not greyed out)
3. The help pages for the feature says the hyphenation point should be able to be removed

Questions:

1. Is the issue that you cannot remove all hyphenation points?
   (If so, bug is that Remove button is not greyed out.)
2. Are the (greyed out - I'm unsure) Left and Right arrows intended to move the hyphenation point?
   (If so, the bug seems that these buttons are greyed out.)


-- From here on is just a background note: TL;DR? --

Incidentally, even Knuth in his 1981 paper, Breaking Paragraphs into Lines (http://www.eprg.org/G53DOC/pdfs/knuth-plass-breaking.pdf) states:
"The choice of proper hyphenation points is an important but difficult subject that is beyond the scope of this paper", after giving a few good principles

"It is considered bad form to insert a hyphen unless at least two letters precede it and three follow it; furthermore the syllable following a hyphen shouldn’t have a silent ‘e’, so we do not admit a hyphenation like ‘sylla-ble’. Smooth reading also means that the word fragment preceding a hyphen should be long enough that it can be pronounced correctly, before the reader sees the completion of the word on the next line; thus, a hyphenation like ‘pro-cess’ would be disturbing. This pronunciation rule accounts for the fact that the second-last word of Figure 1 does not admit the potential hyphenation ‘fa-vorite’, since the fragment ‘fa-’ might well be the beginning of ‘fa-ther’ which is pronounced quite differently."

And despite an hour of googling, I can't find any useful references to the selection of hyphenation points in words (to provide the 'break points' Knuth's algorithm needs as its starting point).

And from  it seems I'm not the only person to have discovered this curious lack.
Comment 4 Buovjaga 2019-08-25 11:32:31 UTC
I had to first install hyphen-en package in my Linux package manager. I confirm the result (after formatting paragraph - Text flow - automatic hyphenation), but it just means handover does not have multiple hyphenation points in Hunspell hyphenation source.

https://helponline.libreoffice.org/latest/en-US/text/swriter/guide/using_hyphen.html
https://helponline.libreoffice.org/latest/en-US/text/swriter/01/06030000.html

Luke: even after the word has been automatically hyphenated, you can manually hyphenate it by placing your text cursor after "d" and pressing Ctrl-hyphen on your keyboard.

Like it says in help: "If you insert a manual hyphen in a word, the word is only hyphenated at the manual hyphen. No additional automatic hyphenation is applied for this word. A word with a manual hyphen will be hyphenated without regard to the settings on the Text Flow tab page."

Anyway, suggestions should be filed to https://github.com/hunspell/hyphen/issues