Bug 124242 - Connectors sometimes not glued anymore after moving some shapes in Draw
Summary: Connectors sometimes not glued anymore after moving some shapes in Draw
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Connectors
  Show dependency treegraph
 
Reported: 2019-03-21 14:46 UTC by l0f4r0
Modified: 2019-10-18 21:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description l0f4r0 2019-03-21 14:46:49 UTC
Description:
Sometimes, connectors lose their connections with their assigned shapes after the latter are moved.

Steps to Reproduce:
Actually, this is not so easy to reproduce. Developers need to make multiple tests with different shapes/connectors configuration and be patient because, after a while from my side, it always does end with the bug.

1. Create numerous shapes (maybe 10-15 at least)
2. Connect the shapes together with connectors (1-to-1 or 1-to-any)
3. Move some shapes (don't select connectors). Try to move with the arrow keys and with the mouse. Try to move one shape or multiple shapes at once. Move to one direction, then to another... Reproduce 3 until the bug happens

Actual Results:
SOMETIMES, the connectors don't follow the shapes and lose their dedicated glue points.

Expected Results:
Connectors should ALWAYS remain with their assigned shapes.


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
Version: 6.1.5.2 (x64)
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
Threads CPU : 8; OS : Windows 10.0; UI Render : GL; 
Locale : fr-FR (fr_FR); Calc: CL
Comment 1 Roman Kuznetsov 2019-03-22 08:26:53 UTC
Laurent, can you attach file example?
Comment 2 QA Administrators 2019-09-19 03:15:34 UTC Comment hidden (obsolete)
Comment 3 l0f4r0 2019-10-18 21:22:22 UTC
I cannot confirm the bug anymore intentionally and  thus provide any sample. Let's forget it for a while until it happens to me again by accident ;)
Such a case arise, I will update this ticket!
Comment 4 Roman Kuznetsov 2019-10-18 21:24:38 UTC
(In reply to l0f4r0 from comment #3)
> I cannot confirm the bug anymore intentionally and  thus provide any sample.
> Let's forget it for a while until it happens to me again by accident ;)
> Such a case arise, I will update this ticket!

so let's close it as WFM. You can reopen it when you'll see this problem again