Bug 124315 - Old "Enter pastes clipboard" can still be executed after inserting current date or time.
Summary: Old "Enter pastes clipboard" can still be executed after inserting current da...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: target:6.3.0 target:6.2.5
Keywords:
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2019-03-24 17:14 UTC by Luuk
Modified: 2019-05-13 09:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
see problem description (7.99 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-03-24 17:14 UTC, Luuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luuk 2019-03-24 17:14:47 UTC
Created attachment 150261 [details]
see problem description

Attached file: Untitled 2.ods

Problem: see next description howto reproduct

1) Copy Sheet2 [A3:H3]
2) Paste this in Sheet1 [A6]
3) Move selection to [F6]   (only [F6] will be selected)
4) Use [CTRL]-[+] (numeric keyboard) to 'Shift cells right'   [F6:H6] will be shifted to [G6:I6]
5) Move selection to [I6]   (only [I6] will be selected)
6) Hit [CTRL}+[;]   this will insert the current date in dat field.
7) Hit [ENTER]

Now cels [I6:P6] are selected and contain the values which where pasted in step 2)

I saved the attached file after reproducing these steps......
Comment 1 mulla.tasanim 2019-03-24 19:48:08 UTC
Thank you for reporting the bug.

I can confirm that the bug is present in

Version: 6.2.1.2 (x64)
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL


Version: 6.3.0.0.alpha0+ (x64)
Build ID: 91cdf22b88a4f7bec243c8fb187627e766d3294c
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-08_00:38:10
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 2 Xisco Faulí 2019-03-25 15:38:54 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default; 

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

but not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

@Eike, I thought you might be interested in this issue...
Comment 3 Eike Rathke 2019-03-25 16:02:33 UTC
Doesn't need the complicated steps:
1. copy any cell to clipbaord
2. move to another cell
3. hit Ctrl+; to enter current date, or Ctrl+: (Ctrl+Shift+;) for time
4. hit Enter
=> copied cell selection will be pasted

Notice that after #3 the marching ants are still active and not cleared like on any other cell input, hence the clipboard selection is pasted on Enter.
Comment 4 Luuk 2019-03-25 22:08:30 UTC
Also notice that the 'running ants' are on a 'not-visible' place on screen.

So, if this is not a bug, it could be undesired/unwanted behavior.
(let phrase this with care  😊 )

Questions that come to mind:
1) Is there a possibility to stop the 'running ants' after 1 paste?
2) Is there a possibility to ask i you really want to paste, if the 'running ants'are not visible on screen (i.e. other sheet, or maybe simply on row #10000 when you are currently on row #2
3) a combination of the above, because you do not want to answer a question when pasting for the first time....
Comment 5 Eike Rathke 2019-03-27 18:11:23 UTC
(In reply to Luuk from comment #4)
> 1) Is there a possibility to stop the 'running ants' after 1 paste?
Hit Escape.

> 2) Is there a possibility to ask i you really want to paste, if the 'running
> ants'are not visible on screen (i.e. other sheet, or maybe simply on row
> #10000 when you are currently on row #2
Enter should paste only if there wasn't another paste yet and no other cell input happened, i.e. immediately after a Copy to clipboard. Raising a dialog then IMHO is bad UX. Apparently the date/time entering shortcuts need to clear some state like any other input does, which would solve the described bug.
Comment 6 Luuk 2019-03-30 07:52:48 UTC
"Enter should paste only if there wasn't another paste yet and no other cell input happened,..."
@Eike: That seems to be even better!
Comment 7 Buovjaga 2019-04-24 19:38:27 UTC
Already in oldest commit of Linux 43all
Comment 8 Eike Rathke 2019-05-06 13:36:20 UTC
OOo3.3 didn't have the functionality, so not a regression.
Taking.
Comment 9 Commit Notification 2019-05-06 16:58:57 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/67d95af78b26d799e68859761dfe72771f71aeab%5E%21

Resolves: tdf#124315 clear "Enter pastes" mode and marching ants overlay

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Eike Rathke 2019-05-06 17:04:56 UTC
Pending review https://gerrit.libreoffice.org/71874 for 6-2
Comment 11 Commit Notification 2019-05-07 14:52:12 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/905634202afe1d8562ae321909a40ff6117af2ad%5E%21

Resolves: tdf#124315 clear "Enter pastes" mode and marching ants overlay

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Luuk 2019-05-11 09:55:18 UTC
(In reply to Commit Notification from comment #11)
> Eike Rathke committed a patch related to this issue.
> It has been pushed to "libreoffice-6-2":
> 
> https://git.libreoffice.org/core/+/
> 905634202afe1d8562ae321909a40ff6117af2ad%5E%21
> 
> Resolves: tdf#124315 clear "Enter pastes" mode and marching ants overlay
> 
> It will be available in 6.2.5.
> 
> The patch should be included in the daily builds available at
> https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> https://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

tested, and found no problems with above, in:
https://dev-builds.libreoffice.org/daily/libreoffice-6-2/Win-x86_64@42/2019-05-11_07.53.29/   (Windows 10; LibreOffice 6.2.5.0)
Comment 13 Xisco Faulí 2019-05-13 09:16:16 UTC
(In reply to Luuk from comment #12)
> tested, and found no problems with above, in:
> https://dev-builds.libreoffice.org/daily/libreoffice-6-2/Win-x86_64@42/2019-
> 05-11_07.53.29/   (Windows 10; LibreOffice 6.2.5.0)

Thanks for double checking. Setting to VERIFIED