Download it now!
Bug 124429 - LibreOffice / Writer Crash on Special Character input
Summary: LibreOffice / Writer Crash on Special Character input
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-29 15:04 UTC by Administrator, NDAS
Modified: 2019-10-25 09:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Administrator, NDAS 2019-03-29 15:04:30 UTC
Description:
Application crashes and enters recovery mode when "Insert > Special Character" is selected through the main menu. Crash appears to occur before dialog is shown.

Version: 6.2.1.2
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Linux Mint "Cinnamon" 19.1

Steps to Reproduce:
1. Open document in Writer
2. Select "Insert > Special Character"
3. CRASH

Actual Results:
Application crashes and enters recovery mode when "Insert > Special Character" is selected through the main menu. Crash appears to occur before dialog is shown.

Expected Results:
Show the dialog for special characters.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.1.2
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-03-29 15:18:00 UTC
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: e74de110d16c95414fac7541c8fe6541d4597113
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Does it happen with a blank document?

Could you please try to reproduce it with the version 6.2.2.2 of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 Administrator, NDAS 2019-03-29 16:55:29 UTC
Thanks for the feedback, Xisco.
 
We tried a full update to 6.2.2; unfortunatly, the problem remains / is identical to the one faced in the previously installed edition. For now, the workaround is to use the system character applet instead.
 
Administrator, NDAS
Comment 3 Xisco Faulí 2019-04-12 11:00:47 UTC
which version of gtk3 do you use ? Does it crash if you launch LibreOffice with SAL_USE_VCLPLUGIN=gen ?
Comment 4 Administrator, NDAS 2019-04-12 13:05:29 UTC
"which version of gtk3 do you use ? Does it crash if you launch LibreOffice with SAL_USE_VCLPLUGIN=gen ?"
 
Hi Xisco,

The standard OS thoughout NDAS is [currently] Linux Mint 19. Please briefly explain how to run this test.

Administrator, NDAS
Comment 5 Xisco Faulí 2019-04-17 14:58:12 UTC
(In reply to Administrator, NDAS from comment #4)
> "which version of gtk3 do you use ? Does it crash if you launch LibreOffice
> with SAL_USE_VCLPLUGIN=gen ?"
>  
> Hi Xisco,
> 
> The standard OS thoughout NDAS is [currently] Linux Mint 19. Please briefly
> explain how to run this test.
> 
> Administrator, NDAS

Go to the console and execute 'SAL_USE_VCLPLUGIN=gen soffice'
Comment 6 QA Administrators 2019-10-15 02:29:43 UTC Comment hidden (obsolete)
Comment 7 bugs.documentfoundation-sammy 2019-10-23 12:22:23 UTC
Hey,
I experience this bug as well.

I already tried to debug with gdb:

Thread 1 "soffice.bin" received signal SIGSEGV, Segmentation fault.
0x00007f0fbd88fe3c in rtl_uString_assign () from /usr/lib/libreoffice/program/libuno_sal.so.3

If I start with 'SAL_USE_VCLPLUGIN=gen' it also crashes:

[New Thread 0x7fd2a673d700 (LWP 2783)]
[New Thread 0x7fd2a59a9700 (LWP 2784)]
[New Thread 0x7fd2d87fc700 (LWP 2785)]
[Thread 0x7fd2a673d700 (LWP 2783) exited]

Thread 1 "soffice.bin" received signal SIGABRT, Aborted.
0x00007fd3281ed7bb in raise () from /lib/x86_64-linux-gnu/libc.so.6

My about LibreOffice:
Version: 6.3.2.2
Build-ID: 1:6.3.2-1~bpo10+1
CPU-Threads: 4; BS: Linux 4.19; UI-Render: Standard; VCL: kde5; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

I'm on Debian buster (x64) and installed LO from backports.
Comment 8 Xisco Faulí 2019-10-23 13:52:19 UTC
it shouldn't be the same. you're using KDE5 while the original report is for GTK3.

@bugs.documentfoundation-sammy@balkonien.org, did you try with a clean profile ?
Comment 9 bugs.documentfoundation-sammy 2019-10-24 07:06:42 UTC
Thanks for your suggestion.
Actually the input of special characters work with a clean profile.
Should I mark the bug as resolved now?

And do you have an idea about how to get this working with my real profile?
Comment 10 bugs.documentfoundation-sammy 2019-10-25 09:12:08 UTC
Okay.
Actually it works now. I just clered my cache.
Thanks for the help. I mark this issue as resolved now.