Download it now!
Bug 124455 - EDITING: Edit Index Entry impossible for 1st key in alphabetical index
Summary: EDITING: Edit Index Entry impossible for 1st key in alphabetical index
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2019-03-31 17:51 UTC by Robert Großkopf
Modified: 2019-05-14 00:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots of "Edit Index Entry" in LO 6.2.2.2 and LO 6.1.5.2 (42.33 KB, application/pdf)
2019-03-31 17:51 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2019-03-31 17:51:40 UTC
Created attachment 150429 [details]
Screenshots of "Edit Index Entry" in LO 6.2.2.2 and LO 6.1.5.2

This bug first appears in LO 6.2.*, works right in LO 6.1.5.2:

Open a document and create some index-entries for an alphabetical index. Try to set "1st key" in the combobox. Combobox is greyed out. Impossible to set a cursor there.

Try the same in LO 6.1.5.2: Combobox is set white. Cursor could be set an "1st key" could be written.

Attachment shows screenshots of the buggy behaviour.

Test versions:
Version: 6.2.2.2
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 6; OS: Linux 4.12; UI render: default; VCL: gtk3; 
Locale: en-US (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.1.5.2
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 6; OS: Linux 4.12; UI render: default; VCL: gtk2; 
Locale: en-US (de_DE.UTF-8); Calc: group threaded

The bug isn't identical to bug 123995. Bug 123995 is reported for older LO-versions, because it is a bug for user-defined indexes.
Comment 1 gilbert.sneed@yahoo.fr 2019-05-04 10:07:36 UTC
I encounter the same problem on my version of LibreOffice (6.2.2) on Linux Debian AND64 9.8.0. Impossible to fill the two boxes. I am not sure it worked on 6.1.5, but I think it workes on old versions like 5.x.
I asked for a solution on LibreOffice site (libreoffice.org). My question is in French, its title is "Impossible de saisir les mots clefs à la création d'une entrée d'index sur writer"
Comment 2 Dieter Praas 2019-05-05 19:32:03 UTC
(In reply to gilbert.sneed@yahoo.fr from comment #1)
> I encounter the same problem on my version of LibreOffice (6.2.2) on Linux
> Debian AND64 9.8.0. Impossible to fill the two boxes. I am not sure it
> worked on 6.1.5, but I think it workes on old versions like 5.x.
> I asked for a solution on LibreOffice site (libreoffice.org). My question is
> in French, its title is "Impossible de saisir les mots clefs à la création
> d'une entrée d'index sur writer"

Gilbert, if you're able to reproduce a bug, you are allowed to change status to NEW

=> I change status to NEW because of comment 1
Comment 3 gilbert.sneed@yahoo.fr 2019-05-05 20:05:42 UTC
I controled a text file I created before july 2016 (I don't remember exactly when, where the key words have been entered. When I want to edit the entries the key words do not appear. Though when I create a new lexical index in that document, it uses the key words as if I just had entered them.
Comment 4 raal 2019-05-09 19:07:25 UTC
@Caolán, it doesn't works in gtk3, but it works in gen. Some "welding" problem.. Thanks

Version: 6.3.0.0.alpha0+
Build ID: 64faea31f7d05e46fe5c91f87381ec7abae90174
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Version: 6.3.0.0.alpha0+
Build ID: 64faea31f7d05e46fe5c91f87381ec7abae90174
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 5 Commit Notification 2019-05-10 08:02:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6546d8ad9645c3d0a2dbc726563f519dafc739f4%5E%21

Resolves: tdf#124455 GtkComboBox text entry greyed out

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2019-05-10 08:04:08 UTC
fixed in master, backport to 6-2 in gerrit
Comment 7 Commit Notification 2019-05-11 06:53:08 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/d49255efea55252d6a92a000b1c53d35c2c5ac8d%5E%21

Resolves: tdf#124455 GtkComboBox text entry greyed out

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2019-05-13 11:25:56 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 630db80d17616d635cf2e5f1d5a0852428b794a3
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!
Comment 9 Commit Notification 2019-05-13 15:15:30 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-4":

https://git.libreoffice.org/core/+/c815d2e5a45f7436121da8b19614a208b1d2d070%5E%21

Resolves: tdf#124455 GtkComboBox text entry greyed out

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.