Bug Hunting Session
Bug 124456 - Make Ant configue.ac check more robust
Summary: Make Ant configue.ac check more robust
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All All
: medium normal
Assignee: Dennis Schridde
URL:
Whiteboard: target:6.4.0
Keywords: patch
Depends on:
Blocks:
 
Reported: 2019-03-31 18:07 UTC by Dennis Schridde
Modified: 2019-10-07 07:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
libreoffice-6.2.2.2-stricter-ant-check.patch (584 bytes, patch)
2019-03-31 18:08 UTC, Dennis Schridde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2019-03-31 18:07:58 UTC
Description:
Attached patch makes the configure.ac check for Ant more robust by specifically searching for the line containing the version information.

See-Also: https://bugs.gentoo.org/682156
See-Also: https://bugs.gentoo.org/682136

Steps to Reproduce:
At least on Gentoo, Ant is wrapped in a shell script that might output additional lines.  This would lead to the build of LibreOffice 6.2.2.2 failing with following message: checking whether Ant is >= 1.6.0... ./configure: line 39234: test: determine because are have 1: integer expression expected

Actual Results:
checking whether Ant is >= 1.6.0... ./configure: line 39234: test: determine because are have 1: integer expression expected

Expected Results:
LibreOffice's configure.ac should ignore any extraneous lines in the output of `ant -version` and focus on the line containing the version information.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dennis Schridde 2019-03-31 18:08:25 UTC
Created attachment 150430 [details]
libreoffice-6.2.2.2-stricter-ant-check.patch
Comment 2 Dennis Schridde 2019-04-23 07:05:55 UTC
Issue persists with LibreOffice 6.2.3.2.
Comment 3 Xisco Faulí 2019-04-23 17:17:25 UTC
Hello Dennis,
Thanks for providing the patch.
Could you please submit it to gerrit for review ? -> https://wiki.documentfoundation.org/Development/gerrit/SubmitPatch
Comment 4 Xisco Faulí 2019-07-09 14:22:38 UTC
(In reply to Xisco Faulí from comment #3)
> Hello Dennis,
> Thanks for providing the patch.
> Could you please submit it to gerrit for review ? ->
> https://wiki.documentfoundation.org/Development/gerrit/SubmitPatch

Setting to NEEDINFO until Dennis(In reply to Xisco Faulí from comment #3)
> Hello Dennis,
> Thanks for providing the patch.
> Could you please submit it to gerrit for review ? ->
> https://wiki.documentfoundation.org/Development/gerrit/SubmitPatch

Moving to NEW
@Dennis, Please submit the patch to gerrit
Comment 5 Dennis Schridde 2019-10-04 15:02:35 UTC
(In reply to Xisco Faulí from comment #3)
> Could you please submit it to gerrit for review ? ->

Patch: https://gerrit.libreoffice.org/#/c/80233/

License: https://lists.freedesktop.org/archives/libreoffice/2019-October/083563.html

I cannot add myself to the contributors list [1], because I am unable to log in to the wiki ("User cannot be authenticated.").  It would be nice, if someone could do it for me.

[1]: https://wiki.documentfoundation.org/Development/Developers#S
Comment 6 Stephan Bergmann 2019-10-04 16:50:25 UTC
(In reply to Dennis Schridde from comment #5)
> License:
> https://lists.freedesktop.org/archives/libreoffice/2019-October/083563.html
> 
> I cannot add myself to the contributors list [1], because I am unable to log
> in to the wiki ("User cannot be authenticated.").  It would be nice, if
> someone could do it for me.
> 
> [1]: https://wiki.documentfoundation.org/Development/Developers#S

done, see <https://lists.freedesktop.org/archives/libreoffice/2019-October/083564.html> "Re: Dennis Schridde license statement"
Comment 7 Commit Notification 2019-10-06 10:08:47 UTC
Dennis Schridde committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cb060c2fe9e03b49953f43ab605559c4542e2ae4

tdf#124456: Make Ant configure.ac check more robust

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.