Download it now!
Bug 124467 - cannot disable wrap text
Summary: cannot disable wrap text
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.beta1+
Hardware: All Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.5
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2019-04-01 10:52 UTC by Gerald
Modified: 2019-05-21 10:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Wrap text cannot be disabled (191.49 KB, image/png)
2019-04-01 10:54 UTC, Gerald
Details
Auto height resize - before (356.79 KB, image/png)
2019-04-01 10:54 UTC, Gerald
Details
Auto height resize after (179.62 KB, image/png)
2019-04-01 10:55 UTC, Gerald
Details
.ods example (28.00 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-04-01 13:56 UTC, Gerald
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald 2019-04-01 10:52:36 UTC
Description:
Wrap text has many issues on this version;
1. I cannot disable wrap text when all cells or several cells are selected
2. The cell hights automatically resize (become bigger) even when the column widht accommodates all text

Steps to Reproduce:
1. Open a spreadsheet with data. Select all and try remove wrap text.
2. On a spreadsheet you can remove wrap text for a single or a few cells but not all 
3. The automatically changing cell heights bug is difficult to reproduce. Sometimes it works and others it does not.

Actual Results:
Clicking on the wrap text check box only has two options, "undecided" and wrap text. No option to completely remove wrap text. Note, even if I set wrap text for all cells, some do not change the setting and remain at "undecided" or disabled.

Expected Results:
Should be able to disable or enable wrap text for all cells.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
N/A
Comment 1 Gerald 2019-04-01 10:54:04 UTC
Created attachment 150447 [details]
Wrap text cannot be disabled
Comment 2 Gerald 2019-04-01 10:54:49 UTC
Created attachment 150448 [details]
Auto height resize - before
Comment 3 Gerald 2019-04-01 10:55:22 UTC
Created attachment 150449 [details]
Auto height resize after
Comment 4 Wolfgang Jäger 2019-04-01 11:43:37 UTC
All the attachments posted as yet are images.

You (Gerald, the OP) claim the bug to be "Reproducible: Always". Thus you surely have an example .ods demonstrating the issue. Please attach it.
Comment 5 Gerald 2019-04-01 13:56:11 UTC
Created attachment 150451 [details]
.ods example
Comment 6 Gerald 2019-04-01 13:57:19 UTC
(In reply to Gerald from comment #5)
> Created attachment 150451 [details]
> .ods example

I have attached an .ods as an example
Comment 7 raal 2019-04-09 02:50:28 UTC
I can confirm "1. I cannot disable wrap text when all cells or several cells are selected"  with Version: 6.3.0.0.alpha0+
Build ID: 31ac398cfa30694b18240d31df17a58d699b5bf6
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Regression, it works in 5.3
Comment 8 Xisco Faulí 2019-05-16 08:04:13 UTC
Hi Caolán, another tristate regression.
It worked fine up to https://cgit.freedesktop.org/libreoffice/core/commit/?id=229483707c3ccb48d008d37f856bbeb6df199a90 when it started to crash. The crash was fixed in https://cgit.freedesktop.org/libreoffice/core/commit/?id=c0a6a4c3ae0116ada31971f80bf383c5bc6c28e8 when the problem is already reproducible
Comment 9 Commit Notification 2019-05-18 20:41:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e79befa6898aef6616adca9e89398242abe9dc5a%5E%21

Resolves: tdf#124467 enable wrap text to return to TRISTATE_INDET

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Caolán McNamara 2019-05-18 20:42:44 UTC
fixed in master, backport to 6-2 in gerrit
Comment 11 Xisco Faulí 2019-05-20 10:06:59 UTC
Hi Caolán, it doesn't seems to work correctly in

Version: 6.3.0.0.alpha1+
Build ID: 9c7fac47aacb0877c7d212217089a680400c1377
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Steps to reproduce:
1. Open The document attached
2. Select all
3. Format Cells - Alignment

- Wrap text automatically is set to INDET and the other two options disabled
OK
- Setting wrap text automatically to FALSE should enable Shrink to fit cell size KO
- Setting wrap text automatically to TRUE should enable Hypernation active
KO

at least this is how it worked in

Version: 6.0.0.0.alpha1+
Build ID: 6eeac3539ea4cac32d126c5e24141f262eb5a4d9
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 12 Commit Notification 2019-05-20 16:28:41 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/115ab48f86d4e3c6eede49767df1ee5a82b4ab22%5E%21

Related: tdf#124467 make the wrap handler act as it did before

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Caolán McNamara 2019-05-20 16:30:11 UTC
2nd go at that, 6-2 backport updated to include new change
Comment 14 Xisco Faulí 2019-05-21 10:36:33 UTC
Verified in

Version: 6.3.0.0.alpha1+
Build ID: 38ac0586448d4f07811b139f62f62686b029feba
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 15 Commit Notification 2019-05-21 10:52:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/23ccf16e9e86ecc64367f41f4df695d0a6926d72%5E%21

Resolves: tdf#124467 enable wrap text to return to TRISTATE_INDET

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.