Bug 124473 - LibreOffice calc not paste japanese kanji symbol with furigana
Summary: LibreOffice calc not paste japanese kanji symbol with furigana
Status: RESOLVED MOVED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-01 15:10 UTC by Army_bloodcore
Modified: 2020-08-22 03:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Army_bloodcore 2019-04-01 15:10:48 UTC
Description:
Hello everyone!
When I copying the Japanese kanji symbol with furigana (phonetic guide) from any LibreOffice writer to LibreOffice calc, it not paste.
Hiragana and Katakana paste normal, kanji with furigana LibreOffice calc ignores. When I paste kanji with hiragana from LibreOffice to notepad, I've got text like this:
だいたいの範囲
LibreOffice text looks like this:
 だいたいの

Steps to Reproduce:
1. Write something in japanese like に関して.
2. and mark it phonetic guide (関=かん).
3. Copy result to clipboard.
4. Paste in LibreOffice calc

Actual Results:
Kanji will be removed

Expected Results:
Kanji will be save, phonetic guide must be in the round brackets after symbol.



Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 himajin100000 2019-04-21 19:48:55 UTC
I can reproduce this bug. Marking NEW.

nitpick:
NEEDINFO is not Reporter would use.

https://bugs.documentfoundation.org/page.cgi?id=fields.html#bug_status

>The report is not complete to determine whether the described problem is a bug and we need additional information or actions **from the reporter**.
Comment 2 himajin100000 2019-04-21 21:48:45 UTC
1. Probably, Default Pasting Format is RTF
2. All fields but hyperlinks are ignored.

https://opengrok.libreoffice.org/xref/core/sc/source/filter/rtf/rtfparse.cxx?r=8f7c3507#57

(snip)

https://opengrok.libreoffice.org/xref/core/editeng/source/editeng/eertfpar.cxx?r=3010e0a6#556

3. Phonetic guides in RTF are implemented using fields.

FYI: Nothing is output to html for phonetic guides, so using HTML format will not work as a workaround.
 
https://opengrok.libreoffice.org/xref/core/sw/source/filter/html/css1atr.cxx?r=507ac9b8#3553
Comment 3 Army_bloodcore 2019-04-22 15:32:13 UTC
Plz, do it silent, mail notification is annoying, and hope this will be in a new updates of libreoffice.
Comment 4 Army_bloodcore 2020-05-15 21:48:26 UTC
I confirm it with LibreOffice 6.4.3.2.
It still not fixed!
Comment 5 Army_bloodcore 2020-06-04 16:44:02 UTC
This bug is VERY actual for me and my projects. I remind about this, it is very important to fix it ass soon ass possible.
Comment 6 Army_bloodcore 2020-08-22 03:21:04 UTC
This bug is not actual for me anymore.