Download it now!
Bug 124527 - french dot keybord (maj + ";") not working in Firefox 66 Ubuntu -- OK in chromium
Summary: french dot keybord (maj + ";") not working in Firefox 66 Ubuntu -- OK in chro...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice Online
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
: 124749 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-04-03 15:10 UTC by Vincent Lucy
Modified: 2019-05-03 12:36 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Lucy 2019-04-03 15:10:03 UTC
All is in the title

in the numeric part of the french keyboard the dot is functioning, not with the combination maj + ";" chich is the only one directly accessible on notebooks.

This appeared with Mozilla Firefox 66 (previously it worked) and does not appear on Chromium.

When turning on the debug on the server we see that no keystrock is received/processed.
Comment 1 romrom 2019-04-07 14:37:44 UTC
Can confirm on the latest Collabora docker image.
Comment 2 Vincent Lucy 2019-04-08 09:51:48 UTC
The keystrock maj + ";" works well with Firefox 63.0b13 (64 bits)(from ubuntu snap channel edge)
Comment 3 Aron Budea 2019-04-23 07:38:36 UTC
*** Bug 124749 has been marked as a duplicate of this bug. ***
Comment 4 Aron Budea 2019-05-03 12:36:37 UTC
This patch, posted in the duplicate report solves the issue. Thanks to Henry and Iván for working on this!

Iván Sánchez Ortega committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/online/+/e6576f0447d28e4fad7b5bcc2aadede20830caaa%5E%21

tdf#124749:loleaflet: use "KeyboardEvent.key" to detect ignored key events