Download it now!
Bug 124532 - Paste (Ctrl-V) from non-LibreOffice apps does not work
Summary: Paste (Ctrl-V) from non-LibreOffice apps does not work
Status: RESOLVED DUPLICATE of bug 62196
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-03 18:02 UTC by Jim Weisenbach
Modified: 2019-04-03 19:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Weisenbach 2019-04-03 18:02:27 UTC
Description:
When attempting a Copy-Paste from any non-LibreOffice app, the pasted text is whatever I had last copied from within LibreOffice... the 'clipboard' doesn't seem to get updated.  Yet, if I 'paste' into some other app (Notepad, Wordpad, email client) the correct text is pasted.

I cannot resolve this problem unless I close *all* portions of LibreOffice and restart it.  After restarting, it will work correctly for an undefined period of time -- hours...days...weeks(?), but returns for no apparent reason.

This began several versions ago, but I had always hoped it would be fixed with the next upgrade.  Latest upgrade is no different in this regard.

Steps to Reproduce:
1.Cannot 'provoke' this error... but once it begins, the only solution is to close all elements (I usually have 2 spreadsheets and 2 word-processing windows opened), and then restart LibreOffice.


Actual Results:
Text that had been last 'copied' from a LibreOffice component is 'pasted' instead of the text newly 'copied' from email (Thunderbird) or web browser (Chrome).  Newly copied text will paste correctly into non-LibreOffice apps.

Expected Results:
Newly copied text should've been pasted into Write or Calc.


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes

I do not suspect UserProfile because the problem is gone after a 'normal' restart.
Comment 1 V Stuart Foote 2019-04-03 18:34:18 UTC
Absent work on bug 60252 enhancement, I'd suggest you install a clipboard viewer like NirSoft's "Inside Clipboard" or Comfort Software's "Free Clipboard Viewer" you can then follow what is on the clipboard cache.

Otherwise this is a duplicate of bug 62196

*** This bug has been marked as a duplicate of bug 62196 ***
Comment 2 V Stuart Foote 2019-04-03 19:44:16 UTC
As noted in dupe bug 62196, some recent rework of the Windows clipboard calls--worth retesting with current 6.2.2 release, or 6.2.3 pre-release [1], or on a master/6.3.0alpha0+ nightly [2]--and letting us know result.

=-ref-=
[1] https://dev-builds.libreoffice.org/pre-releases/win/x86_64/

[2] https://dev-builds.libreoffice.org/daily/master/