Bug 124536 - Crash while opening Chinese documents
Summary: Crash while opening Chinese documents
Status: RESOLVED DUPLICATE of bug 128101
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: ARM Android
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-03 19:14 UTC by kds
Modified: 2020-04-08 06:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample document (1.22 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-04-05 08:46 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kds 2019-04-03 19:14:53 UTC
Hi,

I am working on "6.1.0.0.alpha0+" source. When I launch the app and try to open Chinese or any Asian fonts documents the app crashes & it says:-

"libo:sal/osl/unx/file: failed to open /assets/share/dict_zh.data" 

Can anyone please help.

Thanks
Comment 1 Xisco Faulí 2019-04-04 07:56:33 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 kds 2019-04-04 16:36:02 UTC
(In reply to Xisco Faulí from comment #1)
> Thank you for reporting the bug. Please attach a sample document, as this
> makes it easier for us to verify the bug. 
> (Please note that the attachment will be public, remove any sensitive
> information before attaching it. 
> See
> https://wiki.documentfoundation.org/QA/
> FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help
> on how to do so.)
> 
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' once the requested document is provided.


Hey Xisco,

Thanks for revert. Since it is public document you can download it from :-

http://zt.360.cn/1101061855.php?dtid=1101062514&did=210845178

Kindly verify.

Thanks
Comment 3 Xisco Faulí 2019-04-05 08:46:06 UTC
Created attachment 150543 [details]
sample document
Comment 4 kds 2019-04-08 13:29:30 UTC
Hey Xisco,

Any update on this ? 

Thanks
Comment 5 baffclan 2019-10-12 03:23:41 UTC
Crash with attachment 150543 [details].

LibreOffice Viewer / Android
Version: 6.4.0.0 alpha0+
BuildID: ff2b56672203
Android-ARM@24-Bytemark-Hosting/2019-10-07_11.53.41
Comment 6 Xisco Faulí 2019-10-21 11:45:37 UTC
(In reply to baffclan from comment #5)
> Crash with attachment 150543 [details].
> 
> LibreOffice Viewer / Android
> Version: 6.4.0.0 alpha0+
> BuildID: ff2b56672203
> Android-ARM@24-Bytemark-Hosting/2019-10-07_11.53.41

it should be fixed in master now

Info from ESC meeting:
    + Android viewer
       + Issue when opening any document? (Xisco)
         + Should be fixed (Cloph)

Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 7 baffclan 2019-10-22 03:31:26 UTC
Reproduce with Newest LibreOffice Viewer.

LibreOffice Viewer / Android
Version: 6.4.0.0.alpha1+
BuildID: 3aaa2ec8c603
Android-ARM@24-Bytemark-Hosting/2019-10-21_22.04.56
Comment 8 Christian Lohmaier 2019-11-08 16:09:29 UTC
different cause than the other crashes - this time it is due to using different conditionals in the code as to when to compile-in the break-iteration rules and when to store them in separate .data files.
So they are compiled into the library, but the layouting code thinks it needs to load them separately.
Comment 9 Commit Notification 2019-11-19 14:22:22 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ddd2a419c56d8c12b4d10376ecfdde9d87d276e3

tdf#124536 android: fix breakiterator mismatch (separate data files for zh/ja)

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2019-11-20 10:13:45 UTC
Hi kds,
Could you please try again with a master build from today -> https://dev-builds.libreoffice.org/daily/master/Android-ARM@24-Bytemark-Hosting/current/
Comment 11 baffclan 2019-11-22 03:24:20 UTC
Reproduce with Newest LibreOffice Viewer.

LibreOffice Viewer / Android
Version: 6.5.0.0 alpha0+
BuildID: 1c58b2a437a7
Android-ARM@24-Bytemark-Hosting/2019-11-22_01.28.26
Comment 12 Michael Weghorn 2019-12-12 12:42:16 UTC
(In reply to baffclan from comment #11)
> Reproduce with Newest LibreOffice Viewer.
> 
> LibreOffice Viewer / Android
> Version: 6.5.0.0 alpha0+
> BuildID: 1c58b2a437a7
> Android-ARM@24-Bytemark-Hosting/2019-11-22_01.28.26

So the problem is still reproducible for you?

I just tried with a current master build (as of commit 9ab43aebad67383057d2cc3f754ce2193fa78b4e), and the document opens fine for me on an x86 Android emulator. Can you please try once more with a daily build, and give some more details on your device and Android version if it still fails?
Comment 13 Michael Weghorn 2019-12-12 12:44:39 UTC
And it would be great to get an ADB log of the crash to see what goes wrong.
Comment 14 baffclan 2019-12-23 04:03:23 UTC
(In reply to Michael Weghorn from comment #12) 
> So the problem is still reproducible for you?

Reproduce with Newest LibreOffice Viewer.

LibreOffice Viewer / Android
Version: 6.5.0.0 alpha0+
BuildID: c9829f585103
Android-ARM@24-Bytemark-Hosting/2019-12-22_23.54.20

OS: Android 9
CPU: ARM Qualcomm
GPU: Adreno(TM) 506
Comment 15 Michael Weghorn 2020-04-07 13:12:23 UTC
(In reply to Michael Weghorn from comment #13)
> And it would be great to get an ADB log of the crash to see what goes wrong.

Any chance to get an ADB log? (without being able to reproduce, it's hard to do anything here...)
Comment 16 Michael Weghorn 2020-04-08 06:18:20 UTC
Let's close this one as a duplicate of tdf#128101, since the reporter is the same for both bug reports and the actual problem is that opening any file crashes.

(s.a. fix in comment 9 which seems to fix the underlying issue for others)

*** This bug has been marked as a duplicate of bug 128101 ***