Bug Hunting Session
Bug 124557 - Assert when clicking the expand formula bar button
Summary: Assert when clicking the expand formula bar button
Status: RESOLVED DUPLICATE of bug 119626
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Formula-Bar
  Show dependency treegraph
 
Reported: 2019-04-04 23:17 UTC by Jan-Marek Glogowski
Modified: 2019-04-10 06:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Assertion when pressing the Calc formular bar expand button (6.00 KB, text/plain)
2019-04-04 23:19 UTC, Jan-Marek Glogowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan-Marek Glogowski 2019-04-04 23:17:11 UTC
soffice.bin: /home/jmg/Development/libreoffice/symbols/vcl/source/window/toolbox.cxx:2286: void ToolBox::ImplFormat(bool): Assertion `item.maCalcRect.Top() >= 0' failed.

This crashes for me in any themed VCL plugin on Linux.
Well it actually doesn't crash with qt5 in the debugger, but without the debugger, so it looks like a timing problem.
It doesn't crash with gen. LO is master a few days old with some addition Qt only patches.

Interestingly the tooltip of the bar is "input bar", the tooltip of the button "expand formular bar".

It is reproducible for me, but given these weird circumstances...
Comment 1 Jan-Marek Glogowski 2019-04-04 23:19:58 UTC
Created attachment 150540 [details]
Assertion when pressing the Calc formular bar expand button
Comment 2 Michael Weghorn 2019-04-10 06:06:33 UTC

*** This bug has been marked as a duplicate of bug 119626 ***