Bug 124573 - Printer extremely slow for each page with anything but normal print setting
Summary: Printer extremely slow for each page with anything but normal print setting
Status: CLOSED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print
  Show dependency treegraph
 
Reported: 2019-04-05 23:26 UTC by 76kenreed
Modified: 2022-05-28 13:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Here's the "About Libre Office" screen for my version (82.39 KB, image/jpeg)
2019-04-07 23:38 UTC, 76kenreed
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 76kenreed 2019-04-05 23:26:50 UTC
Description:
This problem started a couple updates ago.  When I use any printer option except the normal printing option it takes two or three minutes before the printer begins to work.  This repeats for each page, making a five-page print job ten or fifteen minutes long.  Example: I'm going to print five handouts for a meeting.  To save some ink, I select "fast normal" in my printer properties.  It will take two or three minutes for the printer to begin printing, and then it prints the first copy at normal speed.  Then there is another two or three minute delay before the second copy begins to print.  This continues for each page until the document finally finishes.
   The problem seems to be worse with the word processor, but it seems like the spreadsheets have some trouble printing out in anything but normal setting as well, although it's not nearly as slow.  Note that this is not a problem with any of my other applications, such as when printing within Firefox or Chrome, nor was it a problem with Libre Office until about 18 months ago.  BTW, I'm using an older HP PSC 1410 all-in-one printer, directly connected to my computer.

Steps to Reproduce:
1.Bring up a one or two-page word-processing file, with fairly full pages of text.
2.Try to print five or six copies of the document, selecting a mode other than normal printing, such as fast normal or draft mode.  Trying to print on both sides of the page will likely stall the job for each page as well.
3.Compare the print speed (which should be faster!) against normal printing.  It's taking two or three pages of wait time between pages for me.

Actual Results:
I don't know what I'm supposed to put in here, since I listed the steps to create the problem above.  This seems redundant.

Expected Results:
Printing in "fast normal" should actually be faster than "normal" mode, at least it always used to be, and it is when I print pages directly out of Firefox or Chrome, or my photo editor.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 76kenreed 2019-04-05 23:31:54 UTC
I mistakenly entered at one point that it was taking "two or three pages of wait time" when I meant two or three minutes of wait time.
Comment 2 Roman Kuznetsov 2019-04-07 16:26:23 UTC
PLease add info from dialog Help->About LibreOffice
Comment 3 76kenreed 2019-04-07 23:38:49 UTC
Created attachment 150589 [details]
Here's the "About Libre Office" screen for my version

I was asked for more info from the "About Libre Office" screen.  Here's a screenshot of that.
Comment 4 Xisco Faulí 2019-04-09 12:22:45 UTC
To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?
Comment 5 76kenreed 2019-04-13 18:25:42 UTC
   Per request, I reset the user profile according to the directions, running LibreOffice in safe mode.  Problem was identical.  I tried printing three copies in "fast normal" mode.  It took 1 minute 35 seconds before the first copy began to print, the second copy began printing at the 3:20 mark after a long delay with no printing, and the 3rd copy did not start printing until the 5:30 mark.  Printing each individual page is slower, too, but the biggest issue is that there's just such a huge delay between copies.
   For comparison, when printing out of WordPad in "fast normal" mode, the first page begins printing immediately, the second page starts in just ten seconds, and the third page starts at the 20-second mark.  So it's printing much faster, with no delay at all between copies.  And when printing a copy of this webpage from Firefox in "fast normal" speed, the first copy began printing after 1 second, the second at the 0:31 mark, and the third at the 0:55 mark.
   So it still seems to me that there's something amiss with the printing engine (or whatever it's called now) within LibreOffice.
Comment 6 Watsson Merry 2019-06-08 10:10:53 UTC Comment hidden (spam)
Comment 7 allenstif 2019-09-27 04:56:39 UTC Comment hidden (spam)
Comment 8 Xisco Faulí 2019-10-30 09:29:51 UTC
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 9 76kenreed 2019-11-05 00:36:06 UTC
I am currently using Libre Office version 6.2.8.2.  I again ran a print job on a five-page document.  I set it to print two copies using both sides of the paper, set in the "fast normal" print mode.  Here are the results:
- After a delay of 1 minute 15 seconds the 1st page began printing, but stopped almost immediately and did nothing for 45 seconds; printed a bit more and took another pause, then finally finished printing the first side of the page at 2:38.
- After another long pause, the 2nd page began printing at 3:58, but again timed out a couple of times, and didn't finish printing this second page until 5:32.
- The 3rd page began printing at 6:53, and after a couple of pauses finished printing at 8:38.
-- This pattern continued for the entire 10 sides of the print job, finally finishing at 23:57.  So Libre Office is taking over 2 1/2 minutes to print each page in "fast normal" mode.
-- For comparison, Foxit Reader printed a similar document, 2 copies of a 5-page document, double-sided in "fast normal" mode in 4:53 total, about five times as fast as Libre Office.
** So the short story is, the problem is still there for me. I suspect it has something to do with compatibility with an older printer; I'm using an HP PSC 1410, which works great for everything else.
Comment 10 Buovjaga 2020-04-15 16:15:20 UTC
Is the delay present, if you print to "Microsoft PDF Printer" from LibreOffice?
Comment 11 76kenreed 2020-04-22 22:12:28 UTC
No, the print to .pdf works just fine, but that's no surprise.  Since there's only one mode to print in for the Microsoft .pdf printer, it's not an issue.  The problem occurs when I try to print in anything other than normal mode to my HP printer, for example, back to back printing or especially reduced quality.
Comment 12 Xisco Faulí 2020-11-18 15:25:03 UTC
Hello 76kenreed@gmail.com,
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 13 76kenreed 2020-11-18 20:05:32 UTC
Okay, today I upgraded to version 6.4.7.2, and the problem is, if anything, worse.  I began by trying to print a 3-page letter with a piece of clipart at the beginning and end of the letter.  Note that I printed this letter with no problem using normal settings just a week ago using the previous version of Libre Office.
Today I used the "fast normal" setting for my HP PSC 1410 printer.  The printing started immediately, but began by only printing the clipart at the end of the letter, leaving the rest of page 3 blank.  Then there was a pause of three minutes and five seconds, after which it began printing page 2 and then continued right into page 1.  Page 1 and 2 ended up looking as they should for reduced quality, but as I said, page 3 was blank except for the clipart at the end of what should have been a full page of text.  Printing was slow overall, even though it should have been faster than usual.
Then I tried printing the document using normal settings.  Again it began printing immediately, but again failed to print any of the text on page 3, just printing the ending clipart.  It continued right into page 2, then page 1, with no pause, taking 90 seconds for the full document.
I then tried with a different 3-page document; this time with no clipart, just a few boldface titles.  The first printout, in normal setting, started immediately and ran straight through, finishing all three pages in 55 seconds.  But when I tried printing the same document again using the fast normal setting, printing did not start for 2 minutes and 30 seconds.  It printed page 3 fairly quickly, then paused for almost four minutes before it began printing page 2.  It paused again halfway through the page for one minute, then printed about ten lines and paused again for over three minutes.  It hiccuped along like this until it finally finished the three pages in a total of just under 13 minutes.  At least all three pages were complete.
Sooooo, we don't seem to have made any improvement, at least not in v. 6.4.7.2. I'm concerned that this newer version is not even printing as well as the previous version. I'm not sure I want to try the beta 7.1 version, since things seem to be going backward for me.  Recommendations?
Comment 14 Buovjaga 2020-11-19 05:15:51 UTC
(In reply to 76kenreed from comment #13)
> Sooooo, we don't seem to have made any improvement, at least not in v.
> 6.4.7.2. I'm concerned that this newer version is not even printing as well
> as the previous version. I'm not sure I want to try the beta 7.1 version,
> since things seem to be going backward for me.  Recommendations?

At least a 7.1 daily build will not replace your stable build, but install alongside it: https://dev-builds.libreoffice.org/daily/master/current.html
Comment 15 Xisco Faulí 2022-05-02 11:56:28 UTC
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 16 76kenreed 2022-05-02 20:20:17 UTC
This is a fairly old post now.  I had to give up on Libre Office, bite the bullet, and install MS Office.  So I'm no longer dealing with this printer problem.  Thanks for the efforts to fix the bug in any case.
Comment 17 QA Administrators 2022-05-03 03:42:04 UTC Comment hidden (obsolete)