Bug 124576 - Print preview and printing bug
Summary: Print preview and printing bug
Status: RESOLVED DUPLICATE of bug 120161
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Print Print-Preview
  Show dependency treegraph
 
Reported: 2019-04-06 10:52 UTC by kaye
Modified: 2019-04-11 17:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
For testing print preview (13.21 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-04-06 10:57 UTC, kaye
Details
print_preview lo_6152 vs lo_6073 (99.39 KB, application/pdf)
2019-04-06 15:23 UTC, Oliver Brinzing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaye 2019-04-06 10:52:22 UTC
Description:
YOU CAN GET THE FILE FOR TESTING IN: https://ask.libreoffice.org/en/question/189021/print-preview-and-printing-bug/

Hello Friends

Print preview does not show accurate settings made in Page Style window (press Alt-O-P)

Actual printing is also affected.

This is on LibreOffice 6.1.5.2

Older version 6.0.3.2 does NOT have this problem.

Thanks much!

Steps to Reproduce:
1. Please open the file. Select all cells with borders, i.e. from B4 to H14

2. Press Alt-O-P to go to Page Style

3. Under Page tab, set Format to Letter (8.5x11.00) , Orientation Portrait. Margins: Left, Right and Bottom set to 0.20" , Top set to 0.79" Table alignment set to Horizontal

4. Under Header tab, uncheck Header on

5. Under Footer tab, uncheck Footer on

6. Under Sheet tab, Scaling mode set to Reduce/enlarge printout, Scaling factor set to 123%

7. Click ok to exit.

8. Press Ctrl-P to go to Print window

9. Under General tab, choose Selected cells

Actual Results:
The 1/1 that appears below the preview is correct. But look at the preview itself. It looks like it has a one-inch margin on both left and right sides, which is erroneous because we have set it to 0.20", as stated above. If I went ahead and print it on paper, it will look exactly the same as that preview.

Expected Results:
The preview as well as the print-out is supposed to show that the entire selected cells are enlarged enough such that the margins on both left and right sides are approximately 0.20".


Reproducible: Always


User Profile Reset: Yes



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 kaye 2019-04-06 10:57:05 UTC
Created attachment 150563 [details]
For testing print preview
Comment 2 Oliver Brinzing 2019-04-06 15:23:01 UTC
reproducible with 

Version: 6.1.5.2 (x64)
Build-ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: 

but not with:

Version: 6.0.7.3 (x64)
Build-ID: dc89aa7a9eabfd848af146d5086077aeed2ae4a5
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc:
Comment 3 Oliver Brinzing 2019-04-06 15:23:30 UTC
Created attachment 150570 [details]
print_preview lo_6152 vs lo_6073
Comment 4 Oliver Brinzing 2019-04-07 07:03:30 UTC
steps to reproduce:
- open attachment: https://bugs.documentfoundation.org/attachment.cgi?id=150563
- select range B4:H14 (-> 7 columns)
- open print dialog
- select: (*) Selected cells
-> only 6 columns will shown in print preview (and printed)

seems to have startet with:

https://gerrit.libreoffice.org/plugins/gitiles/core/+/5217a2a0bf27e496cc429ee45dff7c239b466ae6

commit	5217a2a0bf27e496cc429ee45dff7c239b466ae6 [log]
author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	Tue Dec 12 22:22:32 2017 +0900
committer Tomaž Vajngerl <quikee@gmail.com>	Wed Dec 13 00:54:48 2017 +0100
tree	b103a823e8c4bb144ea28c9d15286721088f16b9
parent	eb002da913cd1745b039bbc7e519542d7990fb49 [diff]

tdf#114256 add cache criterium when to recalculate page range size

Page range size can only be valid for the input parameters, which
includes the document size, which was not taken into account at all
before. Now we look at all this parameters to decide if we need to
recalculate or not.

Change-Id: Ic52ad7516189b395c66f59aabc374c3da85f6a89
Reviewed-on: https://gerrit.libreoffice.org/46300
Tested-by: Jenkins <ci@libreoffice.org>
Reviewed-by: Tomaž Vajngerl <quikee@gmail.com>

/cygdrive/d/sources/bibisect/bibisect-win32-6.1
$ git bisect good
37bbce04ad7b4918998cf7c8759b17a32d06b3b9 is the first bad commit
commit 37bbce04ad7b4918998cf7c8759b17a32d06b3b9
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Dec 14 06:46:16 2017 -0800

    source sha:5217a2a0bf27e496cc429ee45dff7c239b466ae6

    source sha:5217a2a0bf27e496cc429ee45dff7c239b466ae6

:040000 040000 56e2e61db2291a80f883b72cc5ad7b58101de8c6 b3f8ef9b0aff2225f53c131d5b8b204a08c5a7f2 M      instdir

/cygdrive/d/sources/bibisect/bibisect-win32-6.1
$ git bisect log
# bad: [1d66cc00ca6fd2e562cbed88704051b2f5d989e3] source sha:8d2abb388b0a2423c9b7e1f52373e1b06dd9786f
# good: [29d08f54c2f71ffee4fe12dbb24c5f5cbedecfd2] source sha:6eeac3539ea4cac32d126c5e24141f262eb5a4d9
git bisect start 'master' 'oldest'
# bad: [3ac46f6c41b5044f162a451b10af0dc5afdcc113] source sha:22c7c3f54dbb93f856190c561b2540064c5a767d
git bisect bad 3ac46f6c41b5044f162a451b10af0dc5afdcc113
# bad: [aa87e2b4fca257b364e56d731159caf9884e32dd] source sha:7970cca95027cca9847202c6e8263124a4eb30a6
git bisect bad aa87e2b4fca257b364e56d731159caf9884e32dd
# bad: [c76d72527c9591f94ec82f87130c10fe600502f0] source sha:a5be07d6b627a18f104e2feed063ff9020e8c610
git bisect bad c76d72527c9591f94ec82f87130c10fe600502f0
# good: [29511c6b4a1b32ee7152a65c936b19264d5fb0ed] source sha:7cbedaa94f23a1f7676ff649ee6c19eb3a42dfb0
git bisect good 29511c6b4a1b32ee7152a65c936b19264d5fb0ed
# bad: [e288f27cd67026a1f41ffd9a6cbafe6202f5e87c] source sha:fd88c4b45426600bd09fc47f8df9ac1cb8030e95
git bisect bad e288f27cd67026a1f41ffd9a6cbafe6202f5e87c
# good: [31719d5e3c36ef3d7969d4a3bb40ee8286efb866] source sha:ce652a7f0d2745143a3e1078607a72695ce124f9
git bisect good 31719d5e3c36ef3d7969d4a3bb40ee8286efb866
# good: [d4082b3041b5152309148c6651b62a6a490768ca] source sha:5de99031fa31eaf78d92cf5aa8de6cac8f2f8782
git bisect good d4082b3041b5152309148c6651b62a6a490768ca
# good: [15bd15429debfa798d971cfed7e210503fb5e732] source sha:810b5f6491850d70bfe2da1f58927a3404d37d49
git bisect good 15bd15429debfa798d971cfed7e210503fb5e732
# good: [da9859bf1a7b4a268eaee75ee5cdea8b1bef7b52] source sha:1e70464c380ecc0756ea29098632c503a60aec71
git bisect good da9859bf1a7b4a268eaee75ee5cdea8b1bef7b52
# bad: [0d1dcd0a2a05805c513399989da0efb89aa8d396] source sha:8782ea036e97c383e0a979ed30c8da955c56877b
git bisect bad 0d1dcd0a2a05805c513399989da0efb89aa8d396
# bad: [37bbce04ad7b4918998cf7c8759b17a32d06b3b9] source sha:5217a2a0bf27e496cc429ee45dff7c239b466ae6
git bisect bad 37bbce04ad7b4918998cf7c8759b17a32d06b3b9
# good: [40453ff4aef102d094beacd57a2c2a6cf4c6c013] source sha:dcdaca599987ded1577bd04ed1e70f5bd02e943f
git bisect good 40453ff4aef102d094beacd57a2c2a6cf4c6c013
# good: [e5ff358709ef06ab837a5c75dabf3693f526d8a8] source sha:eb002da913cd1745b039bbc7e519542d7990fb49
git bisect good e5ff358709ef06ab837a5c75dabf3693f526d8a8
# first bad commit: [37bbce04ad7b4918998cf7c8759b17a32d06b3b9] source sha:5217a2a0bf27e496cc429ee45dff7c239b466ae6
Comment 5 Oliver Brinzing 2019-04-07 07:08:34 UTC
btw: not reproducible with:

Version: 6.2.3.1 (x64)
Build-ID: 9ba025bafb03b962c34687cf87806cc03a3a7436
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

and current master:
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 421e6fc3cd2e6fe37afbef341e2d0ad7b8edde37
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 6 Oliver Brinzing 2019-04-07 07:32:10 UTC
i think, this may have been fixed with:

https://bugs.documentfoundation.org/show_bug.cgi?id=120161
PRINTING, PDF Export: Problem with selected cells which cross pages
Comment 7 kaye 2019-04-11 13:00:54 UTC
Hey, apologies if I'm breaking protocol here, I just want to know if this bug is fixed yet.  If fixed, do I install the latest version?

Pardon my ignorance, this is the first time I've ever reported a bug on any free software.

Thank you for your time.
Comment 8 Oliver Brinzing 2019-04-11 17:06:20 UTC
(In reply to kaye from comment #7)
> Hey, apologies if I'm breaking protocol here, I just want to know if this
> bug is fixed yet.  If fixed, do I install the latest version?

you can try with lo 6.2.3 prerelease from:

https://www.libreoffice.org/download/download/?type=win-x86_64&version=6.2.3&lang=de

cause i can not confirm this issue with with lo 6.23/6.3master:
-> setting to resolved, duplicate of 120161

*** This bug has been marked as a duplicate of bug 120161 ***