Bug 124630 - Zoom bar not working well
Summary: Zoom bar not working well
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.5.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Zoom-Issues
  Show dependency treegraph
 
Reported: 2019-04-09 21:07 UTC by dgbates2@gmail.com
Modified: 2019-05-09 06:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
zoomed images at different levels between 100-150 (8.74 KB, application/vnd.oasis.opendocument.text)
2019-04-10 00:47 UTC, Sophia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dgbates2@gmail.com 2019-04-09 21:07:11 UTC
Description:
The doom zoom bar in the lower right of the screen is small and snaps very readily to the 100% mark, meaning I can't select anything between 100% and 152%.

Steps to Reproduce:
1. as described
2.
3.

Actual Results:
as described

Expected Results:
as described


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Mac OS X (All)
OS is 64bit: no
15" screen
Comment 1 Xisco Faulí 2019-04-10 00:39:00 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 Sophia 2019-04-10 00:47:03 UTC
Created attachment 150638 [details]
zoomed images at different levels between 100-150

I recommend you use the  - and  + keys at the lower right of the document when trying to zoom images or letters. It gives you the specification of what exactly you want.
Comment 3 Sophia 2019-04-10 00:47:48 UTC
I recommend you use the  - and  + keys at the lower right of the document when trying to zoom images or letters. It gives you the specification of what exactly you want
Comment 4 Dieter Praas 2019-04-10 07:15:10 UTC
(In reply to Sophia from comment #3)
> I recommend you use the  - and  + keys at the lower right of the document
> when trying to zoom images or letters. It gives you the specification of
> what exactly you want

dgbates2, does this hint solve your problem? If not, what results do you get by using + and - ? => NEEDINFO
Comment 5 Sophia 2019-04-10 08:09:45 UTC
I didn't reproduce the same issue when I tried to use the zoom function.

My environment:

OS: macOS 10.14.4

Version: 6.2.2.2
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 4; OS: Mac OS X 10.14.4; UI render: default; VCL: osx; 
Locale: en-US (en_JP.UTF-8); UI-Language: en-US
Calc: threade
Comment 6 dgbates2@gmail.com 2019-04-10 17:29:05 UTC
Hi, I can set any zoom percentage value by clicking the percentage icon (opening Zoom & View Layout), but while using the bar to change the value, it jumps between 100% and 152%, because of strong cursor snap on 100%.
Entering in-between percentages manually works fine.
This bug is actually an enhancement request.. perhaps the bar can be on a logarithmic scale? The first snap after 100% could be perhaps 110% instead of 152%?

I DLed the latest version and the 'issue' is present still.

I hope that helps.
Comment 7 dgbates2@gmail.com 2019-04-10 17:29:49 UTC
(In reply to Sophia from comment #3)
> I recommend you use the  - and  + keys at the lower right of the document
> when trying to zoom images or letters. It gives you the specification of
> what exactly you want

Using + and - solve the problem, thank you :)
Comment 8 QA Administrators 2019-05-08 21:49:54 UTC Comment hidden (obsolete)
Comment 9 Dieter Praas 2019-05-09 06:21:45 UTC
(In reply to dgbates2@gmail.com from comment #7)
> (In reply to Sophia from comment #3)
> > I recommend you use the  - and  + keys at the lower right of the document
> > when trying to zoom images or letters. It gives you the specification of
> > what exactly you want
> 
> Using + and - solve the problem, thank you :)

=> RESOLVED WORKSFORME