Bug 124660 - CPU at 100 % with gtk3 back-end after a few idle minutes with at least 2 documents open
Summary: CPU at 100 % with gtk3 back-end after a few idle minutes with at least 2 docu...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: GTK3 CPU-AT-100%
  Show dependency treegraph
 
Reported: 2019-04-10 16:25 UTC by Eltomito
Modified: 2020-01-03 19:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eltomito 2019-04-10 16:25:30 UTC
Description:
When I open at least to Writer documents in Writer and leave LO idle for a few minutes (10 minutes is definitely enough), the cpu usage goes up to 100% on one cpu thread.

It doesn't matter if the documents are .odt, .docx, .doc or if they're unsaved empty new documents. There only need to be at least two of them and you mustn't touch them at all for some time.

The spell is broken after making a small edit to one of the two documents and scrolling up or down a little.

I discovered that I could make the bug go away by switching to the gtk2 or the gen (X11) back-end, so I assume its gtk3 specific. I switched to gtk2 by adding the line "SAL_USE_VCLPLUGIN DEFAULT=gtk" without the quotes to .pam_environment.


Steps to Reproduce:
1. Open at least two writer documents of any kind
2. Let them sit idle for 10 minutes.


Actual Results:
The fan starts blowing at full speed and one virtual core maxes out at 100%.

Expected Results:
All CPU cores at idle levels, the fan is quiet.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.2.2.2
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Telesto 2019-04-11 09:48:48 UTC
Pure speculation.. because of different backends.. but has some similarity with bug 123583. In that case it would - at a minimum - be reproducible with 6.0 but not with 5.4
Comment 2 Eltomito 2019-04-11 18:46:19 UTC
(In reply to Telesto from comment #1)
> Pure speculation.. because of different backends.. but has some similarity
> with bug 123583. In that case it would - at a minimum - be reproducible with
> 6.0 but not with 5.4

I vaguely remember this bug appearing around the 6.0 version but I can't guarantee it. Is there an easy way to install 5.4 alongside 6.2? I found v 5.4 in the archive but I'd prefer not having to uninstall v 6.2 because of it.

Thank you!
Comment 3 Telesto 2019-04-11 20:13:00 UTC
(In reply to Eltomito from comment #2)
> I vaguely remember this bug appearing around the 6.0 version but I can't
> guarantee it. Is there an easy way to install 5.4 alongside 6.2? I found v
> 5.4 in the archive but I'd prefer not having to uninstall v 6.2 because of
> it.

It's possible.. Not the expert on this matter..
* There a flatpacks which appear to be working independent
* Or create a separate install following these instructions:
https://wiki.documentfoundation.org/Installing_in_parallel/Linux
https://downloadarchive.documentfoundation.org/libreoffice/old/5.4.7.2/

@Buovjaga
Any additions?
Comment 4 Buovjaga 2019-04-11 20:20:14 UTC
You can use appimages, they do not require an install. Just make them executable either from your file manager by right-clicking and going to properties or chmod +x from the command line.
https://libreoffice.soluzioniopen.com/index.php/old-versions/
https://libreoffice.soluzioniopen.com/index.php/stable-2/
Comment 5 Buovjaga 2019-04-11 20:22:38 UTC
(In reply to Buovjaga from comment #4)
> You can use appimages, they do not require an install. Just make them
> executable either from your file manager by right-clicking and going to
> properties or chmod +x from the command line.
> https://libreoffice.soluzioniopen.com/index.php/old-versions/
> https://libreoffice.soluzioniopen.com/index.php/stable-2/

Bah, forget about the 5.4 builds - they do not come with gtk3!
Comment 6 Eltomito 2019-09-05 19:25:28 UTC
In LO Writer 6.3.0.4 or shortly before, this bug started manifesting even with the gtk2 backend.

Version: 6.3.0.4
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 mattia.b89 2019-09-07 18:57:29 UTC
I am not able to reproduce the issue

Version: 6.3.1.2
Build ID: 6.3.1-1
CPU threads: 4; OS: Linux 5.2; UI render: default; VCL: gtk3; 
Locale: it-IT (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 8 Xisco Faulí 2019-10-16 12:07:16 UTC
(In reply to Eltomito from comment #6)
> In LO Writer 6.3.0.4 or shortly before, this bug started manifesting even
> with the gtk2 backend.
> 
> Version: 6.3.0.4
> Build ID: 057fc023c990d676a43019934386b85b21a9ee99
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
> Locale: en-US (en_US.UTF-8); UI-Language: en-US
> Calc: threaded

mmm, in the original report you used gtk3, now you're using gtk2...
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 9 Eltomito 2020-01-03 16:14:13 UTC
The bug seems to be fixed since 6.0.0.0-alpha1.
Marking resolved.
Comment 10 Telesto 2020-01-03 19:48:58 UTC
Changing status to RESOLVED WFM.