Bug 124691 - Slow mouse wheel scrolling in Writer with GTK3 interface
Summary: Slow mouse wheel scrolling in Writer with GTK3 interface
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.2.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks: GTK3 Scrolling-PageUpDown
  Show dependency treegraph
 
Reported: 2019-04-11 15:38 UTC by Roland Baudin
Modified: 2020-03-15 17:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of complex document with graphics (5.49 MB, application/vnd.oasis.opendocument.text)
2019-04-11 15:38 UTC, Roland Baudin
Details
seems reasonable to me (3.60 MB, video/webm)
2019-04-12 07:57 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Baudin 2019-04-11 15:38:12 UTC
Created attachment 150699 [details]
Example of complex document with graphics

Mouse scrolling complex documents is painfully slow in Writer with the GTK3 interface (on Linux).

I've attached an example document to this bug report.

See also bug #104716 (https://bugs.documentfoundation.org/show_bug.cgi?id=104716).

To reproduce:

1. Open the attached document in Writer with the GTK3 interface and set zoom level to 140%

2. Go to page 104 and scroll around several pages with the mouse. The scrolling is very slow, much slower than scrlling the pages with the keyboard.

3. Open the attached document in Writer with the GTK2 interface and set zoom level to 140%

4. Go to page 104 and scroll around several pages with the mouse. The scrolling is now fluid.

Hardware: HP workstation z820, with two Intel Xeon E5-2687W 0 @ 3.10GHz (16 cores, 32 threads), Nvidia Quadro K2000, 128 GB RAM

System: Ubuntu Linux 18.04 64 bits

Graphics driver: Nvidia 418 or Nouveau
Comment 1 Caolán McNamara 2019-04-12 07:57:18 UTC
Created attachment 150708 [details]
seems reasonable to me
Comment 2 Xisco Faulí 2019-04-12 11:23:05 UTC
Thank you for reporting the bug. To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 3 Roland Baudin 2019-04-13 07:07:17 UTC
I always do the tests with a fresh profile.
Comment 4 Roland Baudin 2019-04-13 07:47:45 UTC
(In reply to Caolán McNamara from comment #1)
> Created attachment 150708 [details]
> seems reasonable to me

Sorry, I forgot to mention the most important thing: this is scrolling with the *mouse wheel* that is slow, not scrolling with the mouse using the scroll bar.
Comment 5 Buovjaga 2019-08-14 16:23:26 UTC
I tested, but mouse wheel scrolling was completely normal with no lag.

Please copy and paste here the contents of your Help - About. This allows us to know more about your system.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: b9a776837462eeb6d50d0decc42604c0c3008eb1
CPU threads: 8; OS: Linux 5.2; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 11 August 2019
Comment 6 QA Administrators 2020-02-11 03:30:13 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2020-03-13 03:09:31 UTC Comment hidden (obsolete)
Comment 8 Roland Baudin 2020-03-15 17:34:20 UTC
The problem is still there with LibreOffice 6.3.5.2 and 6.4.1.2. Scrolling the example document with the *mouse wheel* is painfully slow.

I see the issue in my three computers. My system is Xubuntu 18.04.4, 64 bits.

Here is the content of the About dialog:

Version : 6.4.1.2
Build ID : 4d224e95b98b138af42a64d84056446d09082932
Threads CPU : 8; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: CL

Version : 6.3.5.2
Build ID : 1:6.3.5~rc2-0ubuntu0.18.04.1~lo1
Threads CPU : 8; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: CL

The test was always done with a fresh profile.