Bug Hunting Session
Bug 124700 - LibO6.2 regression: bad misrendering of metafile
Summary: LibO6.2 regression: bad misrendering of metafile
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.1 target:6.2.7 target:6.4.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-04-12 09:01 UTC by sergio.callegari
Modified: 2019-08-15 11:29 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test case (87.71 KB, application/vnd.oasis.opendocument.presentation)
2019-04-12 09:02 UTC, sergio.callegari
Details
Snapshot of misrendering of 2nd slide in LibO6.2 (29.41 KB, image/png)
2019-04-12 09:02 UTC, sergio.callegari
Details
Comparison 6.3 master and 6.1.4.2 (132.21 KB, image/png)
2019-04-16 07:30 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2019-04-12 09:01:31 UTC
Description:
A presentation including a WMF file is rendered incorrectly in editing mode in LibO6.2, with a curve that should be smooth appearing as full of sharp angles. See the second slide of the test case as an example. LibO6.1 renders correctly.

Interestingly enough, LibO6.2 renders the image correctly in presentation mode.

Even more weirdly, in the test case if the first slide is removed and only the problematic slide is retained, the problematic slide starts rendering correctly.
Hope the problem is actually reproducible on the developers machines. Adding a screen snapshot to make sure the very bad misrendering can be seen.

Seen with 6.2.2 final and 6.2.3 RC2

Steps to Reproduce:
see description

Actual Results:
see description

Expected Results:
see description


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 sergio.callegari 2019-04-12 09:02:09 UTC
Created attachment 150711 [details]
Test case
Comment 2 sergio.callegari 2019-04-12 09:02:53 UTC
Created attachment 150712 [details]
Snapshot of misrendering of 2nd slide in LibO6.2
Comment 3 Xisco Faulí 2019-04-16 07:30:49 UTC
Created attachment 150780 [details]
Comparison 6.3 master and 6.1.4.2
Comment 4 Xisco Faulí 2019-04-16 07:36:24 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=32d49d077fff5c63ec731191bff4daed06744afa

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-09-05 23:34:32 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-09-07 10:16:39 +0200
commit	32d49d077fff5c63ec731191bff4daed06744afa (patch)
tree	e1cdfbad4678b38ffc06b8465a4eeb139fda0b76
parent	66c3c53d1951bed03173415d9bce1d7c1e5ac960 (diff)
Cleanup SvpSalGraphics LineGeometry creation

Bisected with: bibisect-linux64-6.2

Adding Cc: to Armin Le Grand
Comment 5 Xisco Faulí 2019-08-13 12:01:38 UTC
Hi Caolán, this is another issue introduced by 32d49d077fff5c63ec731191bff4daed06744afa, which is the same as in bug 122358, which you fixed this week. I thought you might be interested in this one as well
Comment 6 Caolán McNamara 2019-08-13 16:14:12 UTC
If I drop the line path cache and create it new each time then it works, so there might be something wrong with how the cache works, though its not currently obvious what that is
Comment 7 Caolán McNamara 2019-08-14 12:05:31 UTC
I think the same problem exists in windows and its the impPixelSnap where if I compare the cached path with what it would create if allowed to create a new one the values change due to modfication in impPixelSnap
Comment 8 Commit Notification 2019-08-14 19:25:21 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/d72a9f930215b10f6f45a767b0515dcc8ad2b793%5E%21

tdf#124700 don't pull from or insert into cache for PixelSnapHairline

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-08-14 19:28:09 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/91230327fd28d9a021effea62e8cff4836e5a74d%5E%21

tdf#124700 don't pull from or insert into cache for PixelSnapHairline

It will be available in 6.2.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-08-14 19:28:21 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/bd513456710b69ac2f73e983ee1b823d71b3b47b%5E%21

tdf#124700 don't pull from or insert into cache for PixelSnapHairline

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2019-08-15 11:29:33 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: fe00a724a918606e5c8c2c32b155bc50b33d56bd
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!