Bug 124711 - PPT/PPTX: Content of slide changes direction when move on it mouse point (Linux-only)
Summary: PPT/PPTX: Content of slide changes direction when move on it mouse point (Lin...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:ppt, filter:pptx
Depends on:
Blocks: RTL-CTL PPTX PPT
  Show dependency treegraph
 
Reported: 2019-04-12 22:38 UTC by yousifjkadom
Modified: 2019-10-17 11:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
example (339.50 KB, application/vnd.ms-powerpoint)
2019-04-12 22:38 UTC, yousifjkadom
Details
new-lucture (130.28 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-10-14 13:32 UTC, yousifjkadom
Details
before-left-click (125.15 KB, image/png)
2019-10-14 13:35 UTC, yousifjkadom
Details
After-left-click (113.97 KB, image/png)
2019-10-14 13:36 UTC, yousifjkadom
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yousifjkadom 2019-04-12 22:38:30 UTC
Created attachment 150722 [details]
example

Hi. I do not know what I should in title to discribe this bug !

I'm on Fedora 28 X64 Cinnamon edition. Today I take a radical decision to remove system LO & install flatpak LO to enjoy last edition.

Flatpak package working good. But I confronted when started to use impress ! Please look for attached power point (this is only one example). On system LO that I removed there was no such issue that I will discuss !

On flatpak package when I open power point file it will open normally with it's correct direction (in this example from Left to Right). But just when I set pointer of mouse on content of slide (any slide) then direction will reversed into Right to Left ! Moreover, if I tried to correct direction by edit it back to Left to Right it will reverted again to Right to Left !!

Please your kind attention !
Comment 1 Roman Kuznetsov 2019-04-13 07:12:35 UTC
don't repro in

Version: 6.3.0.0.alpha0+
Build ID: 9079da7f62febaf4cef0b77320c31b4e8bb6b5a5
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-04-06_02:52:37
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Can you install LibreOffice from rpm packages from TDF site and try retest your problem?

https://www.libreoffice.org/donate/dl/rpm-x86_64/6.2.2/ru/LibreOffice_6.2.2_Linux_x86-64_rpm.tar.gz
Comment 2 yousifjkadom 2019-04-13 19:24:51 UTC
Hi. You failed to reproduce this bug because your UI in English or other Latin language, correct?

I got this bug when using Arabic UI. But after reading your response, I changed my UI to English & bug disappeared. But when I reset UI on Arabic, the bug re-appearing again.

Please examine the case after change UI into Arabic.
Comment 3 Roman Kuznetsov 2019-04-13 19:36:20 UTC
You can't set up status to NEW, anybody else from QA team should make it
Comment 4 Xisco Faulí 2019-07-09 14:27:06 UTC
Hi,
So this issue is only happening with Flatpak packages?
What happens if you install LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh ?
Comment 5 yousifjkadom 2019-07-12 09:14:48 UTC
(In reply to Xisco Faulí from comment #4)
> Hi,
> So this issue is only happening with Flatpak packages?
> What happens if you install LibreOffice from
> https://www.libreoffice.org/download/libreoffice-fresh ?

Hi. It is not limited to flatpak issue. It is also, occurring on AppImage formate version 6.2.5.2. I did not examine .rpm from source & I will never examine it because I do not like to give root privilege for external package .......

However, my system LibreOffice that installed from my official Fedora repositories has no such issue.

Note: I noticed that if layout of slide involving title field, like slide no. 1 in attached document, then when you click on title field contents then the direction set (changed) to correct one. But if you click over contents of field bellow (field of body of slide) then issue happening !
Comment 6 QA Administrators 2019-07-13 02:48:22 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2019-09-23 13:07:50 UTC
I tried on Windows with Arabic UI, but I am not seeing the problem

إصدارة: 6.4.0.0.alpha0+ (x64)
معرّف البناء: e1b51d4588b4b39592bb94dd5bb90de5e04d061e
خيوط المعالج: 4; نظام التَّشغيل: Windows 10.0; مصيّر الواجهة: المبدئيّ; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-23_09:16:11
المحليّة: fi-FI (fi_FI); لغة الواجهة الرسومية: ar-SA
Calc: threaded
Comment 8 yousifjkadom 2019-10-14 13:30:56 UTC
Hi. I'm started now to suffer this issue with my SYSTEM L.O !

I tried to create new PPT. file for my new lucture & suffered from it !

I attached my new lucture with 2 screenshots (1st before applying mouse left click over contents when contents direction is correct & 2nd after applying mouse left click over contents of slides when issue generated)
Comment 9 yousifjkadom 2019-10-14 13:32:26 UTC
Created attachment 155000 [details]
new-lucture
Comment 10 yousifjkadom 2019-10-14 13:35:40 UTC
Created attachment 155001 [details]
before-left-click
Comment 11 yousifjkadom 2019-10-14 13:36:14 UTC
Created attachment 155002 [details]
After-left-click
Comment 12 yousifjkadom 2019-10-14 13:43:50 UTC
I forgot in my previous comment, (comment 8), to mention that I'm, now, on Fedora 30 X64 Cinnamon edition & my system LO (.rpm package) is: 6.2.7.1 fc30.1-6.2.7.1
Comment 13 Buovjaga 2019-10-14 19:56:00 UTC
What do we need to reproduce this?
1. Arabic locale
2. Arabic UI
3. Arabic locale + UI

Please reply after testing with American English locale and UI and combining with Arabic.
Comment 14 yousifjkadom 2019-10-15 17:13:41 UTC
@Buovjaga

I tried what you asked me to do.

This bug only happening with Arabic UI while Arabic locale has no effect at all.
Comment 15 Buovjaga 2019-10-17 11:00:27 UTC
Ok, this is Linux-only: I repro with Arabic UI, gtk3 and kf5

Arch Linux 64-bit
Version: 6.4.0.0.alpha1+
Build ID: 01d28b0b85f99590c0581e4bbf636bc9281e0571
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 17 October 2019