Bug 124712 - LibreCalc sum function returns a 0 when used to sum data from an imported csv file.
Summary: LibreCalc sum function returns a 0 when used to sum data from an imported csv...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CSV Function-Sum
  Show dependency treegraph
 
Reported: 2019-04-12 22:39 UTC by mallardw
Modified: 2019-04-14 06:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mallardw 2019-04-12 22:39:28 UTC
Description:
I imported a csv file from bank and it was properly imported into calc - all data was there and properly formatted. However, the SUM function when used to total columns of numeric data, returned a 0. Other simple operations like add, subtract, etc work fine. The SUM function works fine on a new worksheet or a Microsoft Office Excel file but not the CSV imported file.

Steps to Reproduce:
1.Import a CSV file into Calc
2.Choose a column of numbers and use the SUM function to total values.
3.All other operations like add, subtract seem to work fi

Actual Results:
ne.

Expected Results:
SUM of data was always 0


Reproducible: Always


User Profile Reset: No



Additional Info:
Returned the sum of the chosen numbers.
Comment 1 Roman Kuznetsov 2019-04-13 07:02:45 UTC
please attach your csv file and add info from Help->About LibreOffice dialog here
Comment 2 Oliver Brinzing 2019-04-13 07:37:19 UTC
please enable Menu "View - Value Highlighting" to check if the values have been imported as "text" instead of values.
sum function will not work with "text" values.
Comment 3 Oliver Brinzing 2019-04-14 06:38:57 UTC
it turns out, that the values have been imported as "text" instead of values.

https://help.libreoffice.org/Calc/Converting_Text_to_Numbers