Download it now!
Bug 124714 - Writer hangs when opening a simple .ott template
Summary: Writer hangs when opening a simple .ott template
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Template-Manager
  Show dependency treegraph
 
Reported: 2019-04-13 07:23 UTC by Roland Baudin
Modified: 2019-05-03 11:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple test template (8.10 KB, application/vnd.oasis.opendocument.text-template)
2019-04-13 07:23 UTC, Roland Baudin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Baudin 2019-04-13 07:23:59 UTC
Created attachment 150726 [details]
Simple test template

In Linux, LibreOffice Writer hangs when opening a simple template file. The bug is perhaps related to #124644.

To reproduce:

1. Start Writer with a fresh profile

2. Open the attached template

3. Writer hangs and has to be killed

System: Ubuntu Linux 18.04.2 64 bits
Libreoffice 6.2.2.2 downloaded from www.libreoffice.org
Comment 1 raal 2019-04-13 08:06:46 UTC
I can open file without problems
Version: 6.3.0.0.alpha0+
Build ID: 31ac398cfa30694b18240d31df17a58d699b5bf6
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 2 Oliver Brinzing 2019-04-13 08:23:16 UTC
I can't reproduce it in

Version: 6.2.3.1 (x64)
Build-ID: 9ba025bafb03b962c34687cf87806cc03a3a7436
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?
Comment 3 Dieter Praas 2019-04-13 13:31:43 UTC
(In reply to Oliver Brinzing from comment #2)
> To be certain the reported issue is not
> related to corruption in the user profile, could you please reset your
> Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
> re-test?

=> I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 4 Roland Baudin 2019-04-14 07:40:50 UTC
I did the test with a fresh profile (see point 1).

The bug is not present in Windows.
Comment 5 Paul 2019-04-26 20:02:09 UTC
Cannot reproduce using - 

Version: 6.2.3.2
Build ID: aecc05fe267cc68dde00352a451aa867b3b546ac
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Xubuntu 18.04.2 LTS
Comment 6 Dieter Praas 2019-04-27 09:01:22 UTC
(In reply to Roland Baudin from comment #4)
> I did the test with a fresh profile (see point 1).
> 
> The bug is not present in Windows.

But still in Linux like in your original bug report?
Comment 7 Roland Baudin 2019-04-27 12:49:17 UTC
Yes, still in Linux.
Comment 8 Roland Baudin 2019-04-27 13:03:52 UTC
I finally found the cause of the issue... and the solution.

First, the problem only occurs in Linux and is indeed related to the fact that my template XDG directory in the file ~/.config/user-dirs.dirs was set to:

XDG_TEMPLATES_DIR="$HOME/"

I didn't pay attention to the trailing slash in "$HOME/", because everything was OK for years until LibreOffice 6.2.2.1. That trailing slash was here by mistake, I suppose...

Something has changed from that version, because if I remove the trailing slash like this:

XDG_TEMPLATES_DIR="$HOME"

then the problem I've reported disappears, and also bug #124644 doesn't occur.
Comment 9 Hannes 2019-05-03 11:18:06 UTC
Comment #8 fixes the problem for me too.

Version: 6.2.3.2
Build-ID: 20(Build:2)
CPU-Threads: 4; BS: Linux 5.0; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded
Comment 10 Dieter Praas 2019-05-03 11:36:56 UTC
(In reply to Hannes from comment #9)
> Comment #8 fixes the problem for me too.

=> RESOLVED WORKSFORME