Bug Hunting Session
Bug 124729 - Impress reliably crashes on THIS PowerPoint document in Linux
Summary: Impress reliably crashes on THIS PowerPoint document in Linux
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.4.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0 target:6.3.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2019-04-14 08:59 UTC by David Tonhofer
Modified: 2019-12-02 16:33 UTC (History)
6 users (show)

See Also:
Crash report or crash signature: ["libvclplug_gtk3lo.so"]


Attachments
Some document by NASA that impress doesn't like (184.61 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-04-14 09:00 UTC, David Tonhofer
Details
Screenshot: OpenGL disabled results in slight different (but still wrong) behaviour (205.27 KB, image/png)
2019-04-17 07:01 UTC, David Tonhofer
Details
gdbtrace.log with LO 6.4+ from 2019-10-14 in Mint 18.3 (159.93 KB, text/plain)
2019-10-15 09:21 UTC, Timur
Details
gdbtrace.log with LO 6.4+ from 2019-10-15 in Mint 19.2 (256.37 KB, text/plain)
2019-10-16 08:14 UTC, Timur
Details
video capture OpenGL Mint 19.2 (209.06 KB, video/webm)
2019-10-16 08:16 UTC, Timur
Details
minidump from 2019-10-17 in Mint 19.2 (409.76 KB, application/octet-stream)
2019-10-18 09:05 UTC, Timur
Details
gdbtrace.log with LO 6.4+ from 2019-10-17 in Mint 19.2 (254.04 KB, text/plain)
2019-10-18 09:06 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Tonhofer 2019-04-14 08:59:49 UTC
Description:
Attaching a PowerPoint document for which Impress reliably crashes.
This is on:

Fedora 29 (5.0.6-200.fc29.x86_64) 

using LibreOffice:

Version: 6.1.5.2
Build ID: 6.1.5.2-4.fc29
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); Calc: group threaded


Unfortunately I have not been able to create a backtrace because ABRT cannot properly interwork with gdb for some reason (I opened a bug at RedHat for *that*)

Steps to Reproduce:
1) Start presentation
2) Click on "next slide"


Actual Results:
Application crashes.

Expected Results:
Application should display error or otherwise res-stabilize.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
OpenGL is enabled:

OpenGL vendor string: nouveau
OpenGL renderer string: NV94
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.3.6
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.3 (Compatibility Profile) Mesa 18.3.6
OpenGL shading language version string: 3.30
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.3.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
Comment 1 David Tonhofer 2019-04-14 09:00:43 UTC
Created attachment 150740 [details]
Some document by NASA that impress doesn't like
Comment 2 V Stuart Foote 2019-04-14 13:08:33 UTC
Can not reproduce on Windows 10 Home 64-bit en-US with
Version: 6.2.2.2 (x64)
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

All slides of presentation could be traversed. With single monitor (laptop) presentation slide transitions, and animations for multi-element slides, all advance with out issue. 

Probably unrelated, only noticeable issue was some mishandling of Text boxes with fonts set italic leaned outside their stamping box. (Slides 12, 15, 16)
Comment 3 Xisco Faulí 2019-04-16 07:26:10 UTC
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: 0eaa0804085dd6e93257dd31361490720456679d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Does it work if you disable OpenGl ? -> https://wiki.documentfoundation.org/OpenGL

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 4 Timur 2019-04-16 11:28:33 UTC
I reproduced in Linux Mint with LO appimage 6.1 and extracted 6.3+ .
Comment 5 Timur 2019-04-16 12:45:42 UTC
No repro with OO so I'll mark regression. Repro also LO 5.4.6. 
No repro in Windows.
Comment 6 David Tonhofer 2019-04-17 06:59:55 UTC
Recently upgraded to 

libreoffice-6.1.5.2-5.fc29.x86_64

Tried with OpenGL disabled as per comment #3

This results not in a crash, but the projector window disappearing, in a half-drawn dialog "LibreOffice 6.1 Document Recovery" and the application becoming unresponsive. Attaching screenshot.
Comment 7 David Tonhofer 2019-04-17 07:01:06 UTC
Created attachment 150808 [details]
Screenshot: OpenGL disabled results in slight different (but still wrong) behaviour
Comment 8 Timur 2019-04-18 14:57:18 UTC
Worked with 5.2.7.2 but with flickering.
Comment 9 Xisco Faulí 2019-04-25 13:29:15 UTC Comment hidden (obsolete)
Comment 10 raal 2019-04-28 05:29:00 UTC
No repro Version: 6.3.0.0.alpha0+
Build ID: e913727c7ee3af0bb4031c6829abfb3373306492
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 11 Timur 2019-04-29 08:18:13 UTC
(In reply to Xisco Faulí from comment #9)
> (In reply to Timur from comment #4)
> > I reproduced in Linux Mint with LO appimage 6.1 and extracted 6.3+ .
> Do you reproduce it without opengl ?
I tested in VM that doesn't use OpenGL, so yes.
Comment 12 Buovjaga 2019-09-29 18:19:13 UTC
Note that David *did not have* OpenGL UI rendering active when he reported this: "UI render: default;"

So all this talk about OpenGL is a red herring and I have no idea, what David deactivated, when he said he turned off OpenGL.
Comment 13 Xisco Faulí 2019-09-30 09:37:10 UTC
I retested again. It doens't crash in

Version: 6.4.0.0.alpha0+
Build ID: d5b7627a0e738c0866b819910153b96b611813f8
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

nor in

Versión: 6.3.1.2 (x86)
Id. de compilación: b79626edf0065ac373bd1df5c28bd630b4424273
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

@Timur, you moved this issue to NEW, does it mean it crashes for you as well ?
Comment 14 Buovjaga 2019-09-30 10:04:09 UTC
(In reply to Xisco Faulí from comment #13)
> @Timur, you moved this issue to NEW, does it mean it crashes for you as well
> ?

Timur reproduced in comment 4, but it is marked as obsolete. Maybe a lesson for the future not to go overboard in hiding comments :)
Comment 15 Timur 2019-09-30 11:26:24 UTC
Surely it crashes. VM with Mint 18.3. Retested with LO 6.4+. I sent a crash report but no link due to bug 126488 (please set to New!). 
Also crash in 6.3 reported as http://crashreport.libreoffice.org/stats/crash_details/7b2596f2-babf-4966-a1df-6c1ee83c26f5.
Comment 16 Buovjaga 2019-09-30 12:11:34 UTC
Doesn't crash for me FWIW, with gtk3 or kf5

Timur: if possible and if it crashes with a bibisect repo, would be great to see a bibisect result. Probably using 5.4 repo:

git clone https://git.libreoffice.org/bibisect-linux-64-5.4

https://wiki.documentfoundation.org/QA/Bibisect/Linux

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: 2e347c94503321c2102c6f78f5f5bcb771727e69
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 30 September 2019
Comment 17 Timur 2019-10-11 12:29:57 UTC Comment hidden (obsolete)
Comment 18 Timur 2019-10-11 13:06:16 UTC
I hope this is it:

208a2a18a3fbe37e5d1731f81c104f5c66f3691e is the first bad commit
commit 208a2a18a3fbe37e5d1731f81c104f5c66f3691e
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Mon Sep 25 00:19:22 2017 +0200

    source sha:5deb6f29a4038f2de88abbc676e485f5bb5c150d
    
:040000 040000 f25b3dadb22e01a319f28f4a03fae101feb9df37 49c2d4497a674f6578ed7fd958ee6e8b1d9d8136 M	instdir

https://gerrit.libreoffice.org/plugins/gitiles/core/+/5deb6f29a4038f2de88abbc676e485f5bb5c150d%5E!/

commit	5deb6f29a4038f2de88abbc676e485f5bb5c150d	[log]
author	Caolán McNamara <caolanm@redhat.com>	Sun Sep 24 20:35:51 2017 +0100
committer	Julien Nabet <serval2412@yahoo.fr>	Mon Sep 25 00:14:31 2017 +0200
tree	49836d0476ae17f57a0d4f1ab2e948909a55b517
parent	9b9e576368ae36704908086ebc94e5889a7d68e8 [diff]

fix some leaks
Comment 19 Caolán McNamara 2019-10-11 18:56:33 UTC
That would, on the face of it, be an unlikely trigger. When this happens, does it happen in single screen mode, or dual screen mode with the presenter console active ?
Comment 20 Timur 2019-10-12 12:27:17 UTC
To me crash happens in Virtual Box virtual machine, both updated Linux Mint 18 (based on Ubuntu 16.04) and 19 (based on Ubuntu 18.04).
Difference is in Mint 18 crash happens immediately and in 19 on third slide. 
I already wrote there was flickering with LO 5.2, test in the same virtual machine. 
I now tested on another physical Ubuntu 18.04 with LO 6.1 and 6.4+ and no crash but flickering on each slide change. 
So this was never fine.
Comment 21 Commit Notification 2019-10-14 07:53:41 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fb098c51e731ab92198db9822d4de757469ee804

Related: tdf#124729 check error status before continuing

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2019-10-14 07:55:12 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/137e14ec4c3d3258df3802426b5ffe469f7fbde3

Related: tdf#124729 avoid GL_FRAMEBUFFER_INCOMPLETE_ATTACHMENT

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2019-10-14 10:40:39 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8715a067a3547cf91a3ed73fd893a621d5ee1a1c

Related: tdf#124729 check for GL_EXT_texture_filter_anisotropic support

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2019-10-14 12:41:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/bfba5d9e98a4160e53eb07e806c19e30cc8e6947

Related: tdf#124729 check error status before continuing

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Timur 2019-10-15 09:21:40 UTC
Created attachment 155013 [details]
gdbtrace.log with LO 6.4+ from 2019-10-14 in Mint 18.3

Tested with https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF-dbg/current/master_dbg~2019-10-14_16.39.37_LibreOfficeDev_6.4.0.0.alpha0_Linux_x86-64_archive.tar.gz in virtual machine Mint 18.3. 
I still experience crash, as before in Mint 18.3, immediately on slide show run F5. Log attached.
I sent crash report now at 11:something but I don't see the link (bug 126488).
I add that slide show works fine with LO 6.2.8 *installed* from PPA on the same Mint machine (where Appimage 6.2.6 crashes). 
I need to test also Mint 19 where I bibisected this and where crash happened on second or third slide change.
Comment 27 Timur 2019-10-15 10:54:35 UTC
Crash also in Mint 19.
Comment 28 Xisco Faulí 2019-10-15 11:08:40 UTC
(In reply to Timur from comment #27)
> Crash also in Mint 19.

No crash with mint 19.1 here

Version: 6.4.0.0.alpha0+
Build ID: 4704acf63f4fed3a99fc95ff63c82eb5a9ae3908
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 29 Caolán McNamara 2019-10-15 12:46:51 UTC
The relevant lines from the most recent bt, which may not the the same problem as the original report, are...

#3  0x00007ffff77dbc82 in __GI___assert_fail (assertion=0x7fffe7bebd08 "0 && \"Couldn't find current GLX or EGL context.\\n\"", file=0x7fffe7bebcb8 "/tinderbox/buildslave/build/workdir/UnpackedTarball/epoxy/src/dispatch_common.c", line=867, function=0x7fffe7bebd40 <__PRETTY_FUNCTION__.37546> "epoxy_get_proc_address") at assert.c:101
#4  0x00007fffe7b7e450 in epoxy_get_proc_address () at /tinderbox/buildslave/build/workdir/UnpackedTarball/epoxy/src/dispatch_common.c:867
#5  0x00007fffe7b815ef in gl_provider_resolver () at /tinderbox/buildslave/build/workdir/UnpackedTarball/epoxy/src/gl_generated_dispatch.c:73685
#6  0x00007fffe7b8aff7 in epoxy_glGenFramebuffersEXT_resolver () at /tinderbox/buildslave/build/workdir/UnpackedTarball/epoxy/src/gl_generated_dispatch.c:84386
#7  0x00007fffe7bacc67 in epoxy_glGenFramebuffersEXT_global_rewrite_ptr () at /tinderbox/buildslave/build/workdir/UnpackedTarball/epoxy/src/gl_generated_dispatch.c:113854
#8  0x00007fffe0e31c2d in GtkOpenGLContext::ImplInit() () at /tinderbox/buildslave/source/libo-master/vcl/unx/gtk3/gtk3gtkinst.cxx:1479
Comment 30 Caolán McNamara 2019-10-15 12:53:10 UTC
caolanm->Timur: Is there gtk3-demo available on the crashing system? If so, what happens if you run that and try its "OpenGL Area" demo ?
Comment 31 Commit Notification 2019-10-15 14:13:01 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/dae5b97931eb12645565e2ad77b30b5b1c9f9b9c

Related: tdf#124729 check for gtk_gl_area_get_error before continuing

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 32 Commit Notification 2019-10-16 06:17:35 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/223b64a79b6fad317c5b1e7cfba080544376ee07

Related: tdf#124729 check for gtk_gl_area_get_error before continuing

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 33 Timur 2019-10-16 07:06:53 UTC Comment hidden (obsolete)
Comment 34 Caolán McNamara 2019-10-16 07:54:34 UTC
'"Menu "OpenGL Area" just says:
"GtkGLArea is a widget that allows custom drawing using OpenGL calls."
I don't see "Demo". In LO Options-View I don't have OpenGL.'

double click on the "OpenGL Area" entry in the treeview on the left to launch the demo. It should launch a dialog with a opengl triangle in it. My guess is that either the dialog will launch, but show a blank area at the top, or itself crash.

I have some faith that https://git.libreoffice.org/core/commit/dae5b97931eb12645565e2ad77b30b5b1c9f9b9c will make us stop crashing, but will be good to get confirmation of that
Comment 35 Timur 2019-10-16 08:14:05 UTC
Created attachment 155031 [details]
gdbtrace.log with LO 6.4+ from 2019-10-15 in Mint 19.2

I still get a crash, with master_dbg~2019-10-15_16.41.09_LibreOfficeDev_6.4.0.0.alpha0_Linux_x86-64_archive.tar.gz
Comment 36 Timur 2019-10-16 08:16:12 UTC
Created attachment 155032 [details]
video capture OpenGL Mint 19.2

(In reply to Caolán McNamara from comment #34)
> double click on the "OpenGL Area" entry in the treeview on the left to
> launch the demo. It should launch a dialog with a opengl triangle in it. My
> guess is that either the dialog will launch, but show a blank area at the
> top, or itself crash.
Here is a video. I get a triangle, than it becomes black and stays black, no crash.
Comment 37 Caolán McNamara 2019-10-16 11:13:33 UTC
gtk-demo results might suggest that opengl was initially ok, but then failed after a little while.

The #35 crash is a different backtrace than earlier so we seem to have fixed the first crash but still crashed later on
Comment 38 Timur 2019-10-16 12:37:44 UTC
I don't understand why console messages during backtrace are not the same as in gdbtrace.log. 

What I see at console is:

warn:oox:4032:4032:oox/source/helper/propertyset.cxx:137: PropertySet::implSetPropertyValue - cannot set property "IsNumbering" com.sun.star.beans.UnknownPropertyException message: IsNumbering context: SdStyleSheet
warn:oox:4032:4032:oox/source/helper/propertyset.cxx:137: PropertySet::implSetPropertyValue - cannot set property "NumberingLevel" com.sun.star.beans.UnknownPropertyException message: NumberingLevel context: SdStyleSheet
warn:oox:4032:4032:oox/source/helper/propertyset.cxx:137: PropertySet::implSetPropertyValue - cannot set property "NumberingLevel" com.sun.star.beans.UnknownPropertyException message: NumberingLevel context: SdStyleSheet
warn:oox:4032:4032:oox/source/helper/propertyset.cxx:137: PropertySet::implSetPropertyValue - cannot set property "IsNumbering" com.sun.star.beans.UnknownPropertyException message: IsNumbering context: SdStyleSheet
warn:oox:4032:4032:oox/source/helper/propertyset.cxx:137: PropertySet::implSetPropertyValue - cannot set property "NumberingLevel" com.sun.star.beans.UnknownPropertyException message: NumberingLevel context: SdStyleSheet
warn:oox:4032:4032:oox/source/helper/propertyset.cxx:137: PropertySet::implSetPropertyValue - cannot set property "NumberingLevel" com.sun.star.beans.UnknownPropertyException message: NumberingLevel context: SdStyleSheet
warn:svx.uno:4032:4032:svx/source/unodraw/unoshape.cxx:1625: Unknown Property: FromWordArt
warn:svx.uno:4032:4032:svx/source/unodraw/unoshape.cxx:1625: Unknown Property: GraphicColorMode
warn:svx.uno:4032:4032:svx/source/unodraw/unoshape.cxx:1625: Unknown Property: FromWordArt
warn:svx.uno:4032:4032:svx/source/unodraw/unoshape.cxx:1625: Unknown Property: FromWordArt
warn:svx.uno:4032:4032:svx/source/unodraw/unoshape.cxx:1625: Unknown Property: GraphicColorMode
warn:svx.uno:4032:4032:svx/source/unodraw/unoshape.cxx:1625: Unknown Property: FromWordArt
warn:svx.uno:4032:4032:svx/source/unodraw/unoshape.cxx:1625: Unknown Property: GraphicColorMode
warn:oox.vml:4032:4032:oox/source/vml/vmldrawing.cxx:185: DBG_UNHANDLED_EXCEPTION in void oox::vml::Drawing::convertAndInsert() const exception: com.sun.star.uno.RuntimeException message: unsatisfied query for interface of type com.sun.star.drawing.XControlShape! context: SvxCustomShape
warn:oox.vml:4032:4032:oox/source/vml/vmldrawing.cxx:185: DBG_UNHANDLED_EXCEPTION in void oox::vml::Drawing::convertAndInsert() const exception: com.sun.star.uno.RuntimeException message: unsatisfied query for interface of type com.sun.star.drawing.XControlShape! context: SvxGraphicObject
warn:oox.vml:4032:4032:oox/source/vml/vmldrawing.cxx:185: DBG_UNHANDLED_EXCEPTION in void oox::vml::Drawing::convertAndInsert() const exception: com.sun.star.uno.RuntimeException message: unsatisfied query for interface of type com.sun.star.drawing.XControlShape! context: SvxShapeText
warn:oox.vml:4032:4032:oox/source/vml/vmldrawing.cxx:185: DBG_UNHANDLED_EXCEPTION in void oox::vml::Drawing::convertAndInsert() const exception: com.sun.star.uno.RuntimeException message: unsatisfied query for interface of type com.sun.star.drawing.XControlShape! context: SvxCustomShape
warn:oox.vml:4032:4032:oox/source/vml/vmldrawing.cxx:185: DBG_UNHANDLED_EXCEPTION in void oox::vml::Drawing::convertAndInsert() const exception: com.sun.star.uno.RuntimeException message: unsatisfied query for interface of type com.sun.star.drawing.XControlShape! context: SvxCustomShape
warn:oox.vml:4032:4032:oox/source/vml/vmldrawing.cxx:185: DBG_UNHANDLED_EXCEPTION in void oox::vml::Drawing::convertAndInsert() const exception: com.sun.star.uno.RuntimeException message: unsatisfied query for interface of type com.sun.star.drawing.XControlShape! context: SvxGraphicObject
warn:svx.uno:4032:4032:svx/source/unodraw/unoshape.cxx:1625: Unknown Property: FromWordArt
warn:oox.vml:4032:4032:oox/source/vml/vmldrawing.cxx:185: DBG_UNHANDLED_EXCEPTION in void oox::vml::Drawing::convertAndInsert() const exception: com.sun.star.uno.RuntimeException message: unsatisfied query for interface of type com.sun.star.drawing.XControlShape! context: SvxShapeText
warn:legacy.osl:4032:4032:unotools/source/config/moduleoptions.cxx:462: unknown factory
warn:sfx.view:4032:4032:sfx2/source/view/viewfrm.cxx:3192: SID_SIDEBAR state requested, but no task pane child window exists for this ID!
warn:sfx.view:4032:4032:sfx2/source/view/viewfrm.cxx:3192: SID_SIDEBAR state requested, but no task pane child window exists for this ID!
warn:legacy.osl:4032:4032:vcl/source/gdi/bitmap3.cxx:887: BitDepth adaptation failed (!)
warn:legacy.osl:4032:4032:vcl/source/gdi/bitmap3.cxx:814: Bitmap::Scale has changed the ColorDepth, this should *not* happen (!)
warn:vcl.gdi:4032:4032:vcl/headless/svpgdi.cxx:129: unsupported SvpSalGraphics::blendAlphaBitmap case
warn:vcl.gdi:4032:4032:vcl/headless/svpgdi.cxx:129: unsupported SvpSalGraphics::blendAlphaBitmap case
warn:vcl.gdi:4032:4032:vcl/headless/svpgdi.cxx:129: unsupported SvpSalGraphics::blendAlphaBitmap case
Comment 39 Commit Notification 2019-10-16 18:22:23 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8efdbd9a55a753b7c3b7588da234d8eac1b0e3cf

Related: tdf#124729 log any gtk_gl_area_get_error messages

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 40 Timur 2019-10-17 09:29:19 UTC
I wait debug version to be ready.
@David: can you please also test with https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF-dbg/current/ ?

@Caolán: In the meantime, I think you fixed slideshow crash in attachment 152226 [details] from bug 125949, I saw crash with 6.2 and 6.4+ but not with latest master.
Comment 41 Timur 2019-10-18 09:05:52 UTC
Created attachment 155107 [details]
minidump from 2019-10-17 in Mint 19.2

Sorry to say that I still have a crash (and that I cannot write a link for reports I send). Xisco, please help for that. 

Here is a minidump when I ran latest soffice without a backtrace.
Comment 42 Timur 2019-10-18 09:06:54 UTC
Created attachment 155109 [details]
gdbtrace.log with LO 6.4+ from 2019-10-17 in Mint 19.2

Here is gdbtrace.log from ./soffice --backtrace
Comment 43 Caolán McNamara 2019-10-18 10:34:51 UTC
Yeah, that's the same as comment #35. I can actually reproduce that in one of my VMs. Though its unclear to me if that remaining problem is our bug or something in mesa.
Comment 44 David Tonhofer 2019-10-21 14:03:21 UTC
As perc Comment#40, tested with 

LibreOfficeDev_6.4.0.0.alpha1

as a locally installed filetree on Fedora 30.

It works! No crash, document can be traversed!
Comment 45 Timur 2019-10-24 06:48:29 UTC
This is "Fade" transition. Possibly related to bug 91456.
Comment 46 Caolán McNamara 2019-11-28 10:00:59 UTC
Seeing as the original crash of comment #1 is fixed as per comment #44 I'll close this as fixed. I think there is another crash here under some VMs, but I'm not at all sure that crash is "our" crash.
Comment 47 Xisco Faulí 2019-12-02 15:09:39 UTC
@Timur, could you please verify this issue on your end ?
Comment 48 Timur 2019-12-02 16:29:54 UTC
I cannot, I don't have original test VM for some period. 
But I did reproduce a crash after last fix, as written. 
OTOH, that is specific and real progress was made here. 

I test on another Linux laptop with LO 6.2 and see strong flickering. 
So hopefully Fade will be fixed.