Download it now!
Bug 124743 - Tip of the Day should remember latest seen tip and show a new one.
Summary: Tip of the Day should remember latest seen tip and show a new one.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Windows (All)
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks: Dialog-UX Tip-Of-The-Day
  Show dependency treegraph
 
Reported: 2019-04-15 07:48 UTC by Rainer Bielefeld Retired
Modified: 2019-05-15 06:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2019-04-15 07:48:31 UTC
Description:
Every time I launch LibO I see the same "Tip of the day"

Steps to Reproduce:
1. Launch LibO with active "Tip of the Day"
   » Start Center appears
2. click a Recently used document
   » Document and additionally message popup "Tip of the Day" appears


Actual Results:
every time I try the same "palette since 3.5" tip

Expected Results:
A tip I never have seen before appears


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Observed with Server Installation of Version: 6.3.0.0.alpha0+ 
Build ID: 2e3b0c5d42d60d46cd9f8b8eda9424b095c63418; Windows 6.1

Same behavior with newly created user profile and using a copy of my normal user profile

At least some of these Tips are really useful, but I will never reach the last one 😥

BTW: I wonder whether https://nextcloud.documentfoundation.org/s/D6zAC5wddW83xWT (Bug 124658 ) still is used? I did not see "palette since 3.5" tip
Comment 1 Roman Kuznetsov 2019-04-15 08:21:22 UTC
agree

Heiko, I think should be mechanism to display of randomly tip
Comment 2 Heiko Tietze 2019-04-15 10:19:53 UTC
The code should randomly pick one of the 300+ tips (not sequentially because of not storing another value in the registry). Will look into it why it's not working as expected.
Comment 3 Rainer Bielefeld Retired 2019-04-15 12:32:52 UTC
Yes, random might be better than linear
Comment 4 Commit Notification 2019-04-16 08:04:10 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/033e1130a65ec7f0fa9c46e5124adc9d8bf724ba%5E%21

Resolves: tdf#124743 - Tip of the Day randomization

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2019-05-13 09:05:07 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/d1d44e1dde7b1b6001e6b9c672770265ba9cb7db%5E%21

tdf#124743 TipOfTheDay: Next tip should not be random

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Heiko Tietze 2019-05-13 09:55:15 UTC
Justin's patch makes the "Next Tip" sequentially while keeping the first shown random.