Download it now!
Bug 124760 - problemas ao usar o atalho shift+F3
Summary: problemas ao usar o atalho shift+F3
Status: RESOLVED DUPLICATE of bug 49033
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-15 18:33 UTC by Danilo
Modified: 2019-04-15 18:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Danilo 2019-04-15 18:33:35 UTC
Description:
quando utilizo o atalho shift+F3 se for usado na mesma frase ele desfaz toda a alteração já feita, 

Steps to Reproduce:
1.selecionar uma parte de uma frase 
2.alterar com o shift+F3
3.selecionar outra parte na mesma frase
4.alterar com o shift+F3

Actual Results:
desfez a alteração feita anteriormente

Expected Results:
deveria fazer todas as alterações solicitada pelo o atalho shift+F3 e não desfazer as já feitas


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
na versão 5.4 não tinha esse problema de desfazer as alterações, funcionava normalmente
Comment 1 V Stuart Foote 2019-04-15 18:56:16 UTC
The Shift+F3 "cycle case" was modified to also include the "Sentence case" format. Unfortunately "Sentence case" was designed to affect the full sentence run.

Prior to that change, the "cycle case" would affect the word with the text cursor. Or those words included in a text selection. That is still the case--except that as the "Sentence case" is processed selection expands to the full sentence bounds.

See duplicate bug 49033 for eventual resolution.

*** This bug has been marked as a duplicate of bug 49033 ***