Download it now!
Bug 124768 - Exported PDF digital signature conformance with ETSI standard
Summary: Exported PDF digital signature conformance with ETSI standard
Status: RESOLVED DUPLICATE of bug 105856
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2019-04-16 12:19 UTC by Dainius Masiliūnas
Modified: 2020-09-18 07:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dainius Masiliūnas 2019-04-16 12:19:10 UTC
Description:
At the moment, documents signed when exporting a PDF from LibreOffice are almost compliant with the ETSI specification, as reported by the conformance checker, with a single error reported:

5. Error | Tool | Location-{CodeTest}:SubFilter-{CheckIfValueIsOneOfDefined} | Found value: 'adbe.pkcs7.detached''. Allowed values: ETSI.CAdES.detached

So to be compliant with ETSI specs, it should use the ETSI tag rather than the Adobe tag. (Adobe itself supports that as well, see: https://www.adobe.com/devnet-docs/acrobatetk/tools/DigSigDC/standards.html )

Note that the test fully passes when the "sign existing PDF" option is used, via Draw, as opposed to the Export to PDF option from Writer.

Steps to Reproduce:
1. Create a document in Writer.
2. Use the Export as PDF... option
3. Select the certificate in the Digital Signature tab
4. Upload the result to the ETSI conformance checker (https://signatures-conformance-checker.etsi.org/ manual registration needed at the moment).
5. Check report results.

Actual Results:
Failure with one error, about the algorithm to create the signature hash.

Expected Results:
Pass.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2020-02-18 16:50:13 UTC
Hello Dainius,
A new major release of LibreOffice is available since this bug was reported.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 QA Administrators 2020-08-18 05:18:00 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2020-09-18 04:05:57 UTC Comment hidden (obsolete)
Comment 4 Timur 2020-09-18 07:08:58 UTC
This is what can happen with automatic messages. 
Totally not InsufficientData. 
Looks like a duplicate.

*** This bug has been marked as a duplicate of bug 105856 ***