Bug 124770 - FILEOPEN DOCX: Wrong horizontal spacing
Summary: FILEOPEN DOCX: Wrong horizontal spacing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.4.0 target:6.3.4
Keywords:
Depends on:
Blocks: DOCX-Paragraph
  Show dependency treegraph
 
Reported: 2019-04-16 12:30 UTC by Patrick Jaap
Modified: 2019-10-24 12:35 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
sample docx (140.57 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-04-16 12:30 UTC, Patrick Jaap
Details
LO Writer result (9.77 KB, application/pdf)
2019-04-16 12:30 UTC, Patrick Jaap
Details
MSO result (5.03 KB, application/pdf)
2019-04-16 12:31 UTC, Patrick Jaap
Details
LO (master) result (18.02 KB, application/pdf)
2019-04-16 12:56 UTC, Patrick Jaap
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Jaap 2019-04-16 12:30:17 UTC
Description:
In Writer the document is split into two pages, in MSO everything is on one page

Steps to Reproduce:
1. Open the docx file

Actual Results:
two pages

Expected Results:
one page


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Patrick Jaap 2019-04-16 12:30:33 UTC
Created attachment 150788 [details]
sample docx
Comment 2 Patrick Jaap 2019-04-16 12:30:51 UTC
Created attachment 150789 [details]
LO Writer result
Comment 3 Patrick Jaap 2019-04-16 12:31:09 UTC
Created attachment 150790 [details]
MSO result
Comment 4 Dieter 2019-04-16 12:35:23 UTC
I can't see any differences between MSO 2016 and LO 6.2.2.2

Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.

(Additional information: Attachment from comment 2 seems to be wrong)
Comment 5 Oliver Sander 2019-04-16 12:41:18 UTC
I cannot reproduce this either.  I tried

Version: 6.2.2.2
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

and

Version: 6.1.5.2
Build-ID: 1:6.1.5-2
CPU-Threads: 4; BS: Linux 4.19; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group threaded
Comment 6 Patrick Jaap 2019-04-16 12:56:21 UTC
Created attachment 150795 [details]
LO (master) result
Comment 7 Patrick Jaap 2019-04-16 12:58:37 UTC
Thanks for the feedback. I can't reproduce the original problem so there was a false alarm.

But I made sure that I got the Times New Roman font correctly installed and I updated the LO result. There are still some horizontal spacing problems.
Comment 8 Dieter 2019-04-16 13:28:43 UTC
(In reply to Patrick Jaap from comment #7)
> There are still some horizontal spacing problems.

What is exactly the problem? I can't see it.
Comment 9 Patrick Jaap 2019-04-16 13:32:56 UTC
For instance in the third line: MSO 2013 shows the "Lorem" as last word and in Writer it is placed in the fourth line as first word.
Comment 10 Xisco Faulí 2019-04-16 14:06:22 UTC
(In reply to Patrick Jaap from comment #9)
> For instance in the third line: MSO 2013 shows the "Lorem" as last word and
> in Writer it is placed in the fourth line as first word.

it's in the forth line in MSO 2010 too... In my case, MSO 2010 and

Version: 6.3.0.0.alpha0+
Build ID: d7e6c898f5ec8fbd142f9d3e1c46dfcf90edfc27
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

look the same
Comment 11 Dieter 2019-04-17 13:24:48 UTC
I can see some differences (e. g. line 3 and 4), but I can't find a reason: same margins, same characters
=> NEW


Version: 6.3.0.0.alpha0+ (x64)
Build ID: 421e6fc3cd2e6fe37afbef341e2d0ad7b8edde37
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-04-07_01:12:58
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded
Comment 12 Commit Notification 2019-10-21 19:19:20 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6243ea0374aca5bf426a3a70428913166bc2cdc8

Related: tdf#124770 sw doc model xml dump: handle page descriptions

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-10-22 18:07:23 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/dc83c34989b366a9740da062e7d7bdca73fd9890

tdf#124770 sw layout: handle Word's take on italic formatting vs text break

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Miklos Vajna 2019-10-22 21:13:50 UTC
I think this is now fixed on master.
Comment 15 Patrick Jaap 2019-10-23 10:55:49 UTC
I can confirm this is fixed in current master! Thanks!

Can we ask for backports to 6.3 and 6.2 branch?
Comment 16 Miklos Vajna 2019-10-24 09:58:12 UTC
(In reply to Patrick Jaap from comment #15)
> Can we ask for backports to 6.3 and 6.2 branch?

6.2 is now closed (the last release is done from that branch), I'll backport the fix to 6.3, sure.
Comment 17 Commit Notification 2019-10-24 12:35:56 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/8f25d8b610c8b8471584876ae50cd0a86a1bef8f

tdf#124770 sw layout: handle Word's take on italic formatting vs text break

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.