Bug 124836 - CRASH: inserting row and undoing, dependent on ole object?
Summary: CRASH: inserting row and undoing, dependent on ole object?
Status: RESOLVED DUPLICATE of bug 140901
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0 all versions
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, haveBacktrace, regression
Depends on:
Blocks: Undo-Redo
  Show dependency treegraph
 
Reported: 2019-04-19 08:24 UTC by Xisco Faulí
Modified: 2021-10-07 07:40 UTC (History)
7 users (show)

See Also:
Crash report or crash signature: ["ScChart2DataSequence::UpdateTokensFromRanges(ScRangeList const &)"]
Regression By:


Attachments
gdb bt (10.48 KB, text/plain)
2019-04-20 08:39 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-04-19 08:24:07 UTC
Steps to reproduce:
1. Open attachment 75197 [details] from bug 61185
2. Go to Sheet - Row - Insert row above
3. Undo

-> Crash

Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: c9956772ec0678498515fb60dca41e9a77457f86
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-04-19 08:27:29 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

but not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 Timur 2019-04-19 11:03:50 UTC
Repro. 
I'm not clear why I don't see a link in Crash Report.
Comment 4 Xisco Faulí 2019-04-19 13:21:51 UTC
@Dennis Francis, I thought you might be interested in this issue...
Comment 5 Julien Nabet 2019-04-20 08:39:40 UTC
Created attachment 150893 [details]
gdb bt

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 6 b. 2019-04-22 23:20:35 UTC
repro in 4.1.6.2, and 
6.3.0.0.alpha0+ from 2019-04-05, 
so w're dealing with 6-y-o bugs??? 
crazy

b.
Comment 7 Xisco Faulí 2020-01-29 16:12:16 UTC
Hi Eike,
i thought you might be interested in this issue...
Comment 8 b. 2020-01-29 19:16:18 UTC
looks depending on the - not very well defined? - ole object, embedded and represented by the white square at A14:B20, 

1. insert row - undo - crash, 

2. F5 - ole objects - object1 - delete 
insert row - undo - no crash, 

2a. click on object - delete (worked not on all attempts) 
insert row - undo - no crash, 

3. undo until ole object present again 
insert row - undo - no crash, 

4. close without save, reload file, 
insert row - undo - crash, 

5. steps 1-3, save file, 
reopen - insert row - undo - crash, 

steps 3. - 4. no 'stable reproducibility', 

played with ver. 6.4.0.1, 6.4.0.2, 7.0.0.0
Comment 9 b. 2020-01-30 14:54:54 UTC
looked around in #61185, downloaded sheet shows graph, reproducible crash, also on reconstructing similar sheet, ranges for categories and y-values are handeled slightly different, as well for display (second categories range below first, second y-values besides first), as for insert and delete rows: 'categories' range expanded and shrinked, y-values cutted into pieces?

reproducibe crashes with ver. 6.2.8.2, 6.4.0.1, 6.4.0.2 after adding a second range to y-values in a different column (referencing the same column a second time holds) and insert row - undo, adding to categories not neccessary to trigger crash,
Comment 10 Xisco Faulí 2021-10-07 07:40:03 UTC
Nice, this issue got fixed by https://git.libreoffice.org/core/commit/e7ec79fe36a0f22f10167806da80e3c1f30b36e8
Closing as duplicated of bug 140901

*** This bug has been marked as a duplicate of bug 140901 ***