Bug Hunting Session
Bug 124867 - Ignore proper nouns
Summary: Ignore proper nouns
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2019-04-21 09:08 UTC by pvtoine
Modified: 2019-04-23 19:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pvtoine 2019-04-21 09:08:09 UTC
Description:
Spelling correction should have an option to ignore the words beginning by a capital letter ; libreoffice shows me lots of mistakes that are just proper nouns.

Steps to Reproduce:
1.Type a name like Brighton
2.There's a mistake

Actual Results:
Libreoffice shows me a mistake.

Expected Results:
Brighton is a word that exist ; it shouldn't show a mistake.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 Jean-Baptiste Faure 2019-04-21 19:19:23 UTC
Brighton is in the English dictionary. If I type the following sentence
Brighton is a nice city
and set the language for this sentence to English-USA or English-UK, spellchecker does not underline the word.

If I type the sentence
Brighton est une belle ville
and set the language for this sentence to French, spellchecker underlines the word. But if I select the word an set the language for this word to English, the spellchecker is happy.

If you use a lot of foreign proper nouns, you should create a dedicated user dictionary and add each proper noun to it the first time the spellchecker underlines it.

I guess ignoring words beginning by a capital letter is a false good idea because such an option will probably create a lot of corner cases.

I propose to close this enhancement request as WontFix.

Best regards. JBF
Comment 2 pvtoine 2019-04-23 19:28:52 UTC
I'm French (for Brighton). I've lots of mistakes with the names, even if they are French names of famous persons (ministers for exemple).
Maybe an option not enabled by default would be better ?
I guess if it's a useful enhancement other people will propose this, if I am the only one it's not a real problem.
Thanks, I will put it as wontfix.