Bug 124874 - HYPERLINK: Lists in "Target in Document" dialog collapses if you mark text in the document
Summary: HYPERLINK: Lists in "Target in Document" dialog collapses if you mark text in...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Hyperlink-Dialog
  Show dependency treegraph
 
Reported: 2019-04-22 00:07 UTC by S Hutch
Modified: 2020-03-20 07:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document (ODT) with 25 bookmarks, to replicate self-jump scrolling to top of book marks list. (26.21 KB, application/vnd.oasis.opendocument.text)
2019-05-13 16:39 UTC, S Hutch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description S Hutch 2019-04-22 00:07:09 UTC
Description:
UI issue causing major usability annoyance. In Writer, if you have a document with more than approx. 18 bookmarks added, and are then adding Hyperlinks using the "Dcuments/"Target in Document" sub window, upon scrolling the list of Bookmarks below what is visible at the default opening size, the widow after a few seconds will auto-refresh itself and cause the scroll postion of the bookmarks to jump back to the top of the list. 

This occurs very frequently, especially when work with a document with over 15-20 bookmarks and you are working thru the document methoidcally adding hyperlinks (i.e. linking a table of contents etx.) Upon rescrolling the list down ward again to below the first 18 or so entries it will always jump to the top upon stopping scrolling to your location and then force you to do it again. This behavior is unwanted and when you have scrolled to a position lower in the list it should not jump or shift by itself during an editing session, unless you close the "Target in Document list"

Steps to Reproduce:

REPRO STEPS:
- Open a new document in LO Writer, it should have at least 20-30 bookmarks in the document.


Add HyperLink:
- Select "Document" on the Hyperlink pop-up window
- This will open the "Target in Document" pop-up window
- Highlight text in document to add link to
- Target in document" window, scroll down the Bookmarks list to select a bookmark below what is visible upon window opening (i.e #21 or beyond)
- In the Hyperlink dialog, click "Apply", then click Apply in "Hyperlink Window.
- If successful, repeat with another Bookmark further down bookmark list





Actual Results:
RESULT:
- The "Target in document" list upon being scrolled below the lower pane will at some point will auto jump back to Bookmark one. If you then re-scroll down below the pane it will stay at that postion and allow you to select and aapply a link, or two but the often within a thrid or fourth try will again refresh that window causing the list to jump back to the top #1 Bookmark in the list. This jumping upward behavior is frustrating and unwanted.

Expected Results:
Scrolling postion below the lower pane of the intial view should remain in position , unless user input is applied.


Reproducible: Always


User Profile Reset: No



Additional Info:
This has been occuring in Writer perhaps since 6.0 or earlier.
Comment 1 Xisco Faulí 2019-05-13 13:45:11 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 S Hutch 2019-05-13 16:39:10 UTC
Created attachment 151369 [details]
Test document (ODT) with 25 bookmarks, to replicate self-jump scrolling to top of book marks list.

Test document to replicate bevhaior of when adding a hyperlink to a 'Target in Document' bookmark scrolling the bookmark list window below approx. 16-18 items and then waiting the list then self-jumps back to the top of the list frequently.
Comment 3 Dieter 2019-09-20 06:26:37 UTC
I can't confirm this with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: f0c832acb53326ccc9a8c1a47401fbc9e1081feb
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-11_05:46:53
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

and also not with

Version: 6.2.5.2 (x64)
Build-ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 4 QA Administrators 2020-03-19 02:35:17 UTC Comment hidden (obsolete)
Comment 5 S Hutch 2020-03-20 03:25:43 UTC
Still occurs with ver. 6.4.2
The target list if scrolled down partially, then you move to the document pane with mouse to highlight a selection, and then _wait_ a few seconds the target list still frequently snaps to the top of the bookmarks listed within a few seconds.
Comment 6 Dieter 2020-03-20 07:46:50 UTC
(In reply to S Hutch from comment #5)
> Still occurs with ver. 6.4.2
> The target list if scrolled down partially, then you move to the document
> pane with mouse to highlight a selection, and then _wait_ a few seconds the
> target list still frequently snaps to the top of the bookmarks listed within
> a few seconds.

Thank you for additional information. Now I can reproduce it with. Steps to reproduce

1. Opened attachment 151369 [details] from comment 2.
2. Insert => Hyperlink => Document => Target in Document
3. Expand bookmark list (same with headings and sections)
4. Mark some text in the document and wait a few seconds

Result: List collapses
Expected result: List remains open

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 5dcbd1bb557450a2d658a710c163b310c0cee157
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: CL