Download it now!
Bug 124885 - Impress is striping whitespace from presentation notes
Summary: Impress is striping whitespace from presentation notes
Status: RESOLVED DUPLICATE of bug 47825
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-22 12:29 UTC by libreoffice
Modified: 2019-12-06 18:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description libreoffice 2019-04-22 12:29:35 UTC
Description:
Impress is removing all whitespace for Notes when in presentation mode.


Steps to Reproduce:
I have Slide Notes that look like this: (with whitespace including tabs)

"Hello world

My name is:
	Bill
	Fred
	
Also, there's this"

When I go into present mode and it shows notes, I see a solid block of text:
"
Hello world
My name is:
Bill
Fred
Also, there's this
"


Actual Results:
As above

Expected Results:
As Above


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2019-05-13 13:44:17 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 QA Administrators 2019-11-10 03:49:26 UTC Comment hidden (obsolete)
Comment 3 Timur 2019-11-22 10:27:33 UTC
I confirm the behavior in Presentation mode. 
But I find it useful, due to limited space in Notes while reading.
Text itlsef can be printed and formatted, so spaces may be appropriate.

I will close as FontFix.
If you disagree, please explain your use case.
Even and only if justified, this may at most be an enhancement to add an option not to strip those spaces.
Comment 4 Timur 2019-11-22 12:46:48 UTC
To add: I think it's not about stripping whitespaces, but about showing formatted text.
That would add some but small and so far not justified value.
Comment 5 Timur 2019-12-06 18:25:01 UTC
I correct myself, already accepted long ago.

*** This bug has been marked as a duplicate of bug 47825 ***