Bug Hunting Session
Bug 124919 - Increasing text size in table only affects the first cell
Summary: Increasing text size in table only affects the first cell
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords:
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2019-04-23 15:35 UTC by Camaleón
Modified: 2019-05-06 18:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Camaleón 2019-04-23 15:35:59 UTC
Description:
When inserting a table in Writer (2x2), and write down some text on each cell, increasing the text size by using buttons «increase size» and «reduce size» (Ctrl+]), only the first cell (A1) is changed, the rest remain unchanged (no text size is increased nor decreased).

Steps to Reproduce:
1.Insert a table (2x2)
2. Write text in all cells
3. Select the whole table and press «increase size» button, only the text at the first cell in changed (increased)

Actual Results:
Only the text in the first cell (A1) is increased

Expected Results:
All the text inside the table cells should be increased (A1, B1, A2, B2)


Reproducible: Always


User Profile Reset: No



Additional Info:
Versión: 6.2.3.2
Id. de compilación: aecc05fe267cc68dde00352a451aa867b3b546ac
Subprocs. CPU: 4; SO: Linux 4.9; Repres. IU: predet.; VCL: gtk3; 
Configuración regional: es-ES (es_ES.utf8); Idioma de IU: es-ES
Calc: threaded
Comment 1 V Stuart Foote 2019-04-23 16:05:35 UTC
Can not confirm on Windows build with Windows 10 Ent 64-bit en-US (1803) with
Version: 6.2.3.1 (x64)
Build ID: 9ba025bafb03b962c34687cf87806cc03a3a7436
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

Selecting the entire table, and increasing/decreasing font size with shortcut <Ctrl>+[ or <Ctrl>+] or from Sidebar's Properties deck (Character panel), font size in all cells increases/decreases as expected.
Comment 2 Caolán McNamara 2019-04-25 14:47:40 UTC
I see this under gen as well, so not gtk3-specific.

I also see that there's an assert since a91992e7b3e7f59e9116aef859696d517a93dab7 "sw: SwTextNode::GetAttr() inconsistency" that fires on doing this
Comment 3 Caolán McNamara 2019-04-25 16:25:39 UTC
I think I see why this doesn't work, and presumably never did in the case of a complete table selected
Comment 4 Commit Notification 2019-04-26 06:58:05 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/647660cf844f265dd2ad7c78e6cb13844fbf3613%5E%21

Resolves: tdf#124919 fontsize grow/shrink unable to use SwShellTableCursor

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2019-04-26 07:01:21 UTC
works in master, backport to 6-2 in gerrit
Comment 6 Commit Notification 2019-04-26 09:11:55 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/cc2c0439e4b9dcfb141945d9ea5867053a9eb3be%5E%21

Related: tdf#124919 assert on ctrl+[ on four selected cells in table

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-04-26 09:23:59 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/ccf73c63d4638278b458e3d27c2a8c572bb0cb13%5E%21

Resolves: tdf#124919 fontsize grow/shrink unable to use SwShellTableCursor

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-04-26 13:25:19 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/41fa694ed249b778fbafa9c3bf6cbfd53ec6c7cc%5E%21

Related: tdf#124919 assert on ctrl+[ on four selected cells in table

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 BogdanB 2019-05-06 18:00:57 UTC
On older versions after first Ctrl+[ just the first cell was minimized, but after that all the cell.

Now on 6.3 alpha version everything increase/decrease simulataneus from the begining...

Tested with
Version: 6.3.0.0.alpha0+
Build ID: 96ab20756316b25b7f2343a15596bc5114ea5a68
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-02_14:29:16
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded