Bug Hunting Session
Bug 125007 - AdoptOpenJDK is not recognized as JRE
Summary: AdoptOpenJDK is not recognized as JRE
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Java-Runtime-JRE
  Show dependency treegraph
 
Reported: 2019-04-28 08:11 UTC by pierre-yves samyn
Modified: 2019-06-04 06:50 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of AdoptOpenJDK displaying as a JRE in LibreOffice 6.2.4.1 (24.22 KB, image/png)
2019-05-14 14:44 UTC, Alex Brooks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2019-04-28 08:11:32 UTC
Description:
Hi

Env. windows7/64 (2 PCs) & Version: 6.1.5.2 (x64)
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: fr-FR (fr_FR); Calc: group threaded

AdoptOpenJDK is not recognized as JRE => warning message:

*The folder you selected does not contain a Java runtime environment. Please select a different folder.*

Tried with OpenJDK8U-jre_x64_windows_hotspot_8u212b03.msi and also by downloading OpenJDK8U-jre_x64_windows_hotspot_8u212b03.zip and unzipping it in the Java folder.


Steps to Reproduce:
1. Install the jre (either by the installation program or by unzipping)
2. LibreOffice->Tools->Options->LibreOffice->Advanced
3. Tick Use a Java runtime environment (JRE).


Actual Results:
AdoptOpenJDK does not appear in the list.

Click the Add button to add a JRE, navigate & select the jre folder.

Error message: The folder you selected does not contain a Java runtime environment. Please select a different folder


Expected Results:
jre set...


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Download site: https://adoptopenjdk.net/releases.html#x64_win

Also reproduced: https://ask.libreoffice.org/en/question/183834/how-can-i-use-adoptopenjdk-as-the-jre/?comment=191852#post-id-191852
Comment 1 V Stuart Foote 2019-04-28 21:41:46 UTC
Confirmed on Windows 10 Home en-US 64-bit (1809) with
Version: 6.2.3.2 (x64)
Build ID: aecc05fe267cc68dde00352a451aa867b3b546ac
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

However, the AdoptOpenJDK is recognized with current master/6.3.0 for both x86 and x64 installs of AdoptOpenJDK 11 LTS

While not technically a dupe, believe this is also fixed against 6.1.6, 6.2.4 and master/6.3.0 by work on See Also bug 124503
Comment 2 Stephan Bergmann 2019-04-29 07:44:27 UTC
(In reply to pierre-yves samyn from comment #0)
> Env. windows7/64 (2 PCs) & Version: 6.1.5.2 (x64)
> Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
> CPU threads: 2; OS: Windows 6.1; UI render: default; 
> Locale: fr-FR (fr_FR); Calc: group threaded
> 
> AdoptOpenJDK is not recognized as JRE => warning message:

That would mean that <https://gerrit.libreoffice.org/plugins/gitiles/core/+/d801075217375a79ca037df96b3adff5eee5ebd2%5E%21> "Support AdoptOpenJDK", included in libreoffice-6-1-5 (prior to tag libreoffice-6.1.5.2), does not work as intended.

(Which would be somewhat irrelevant as the fix for bug 124503 should indeed get this fixed, through a different internal approach, for LO 6.1.6, but would still be worrisome.)
Comment 3 mechtilde 2019-05-04 07:35:22 UTC
add to CC
Comment 4 Alex Brooks 2019-05-14 14:44:50 UTC
Created attachment 151407 [details]
Screenshot of AdoptOpenJDK displaying as a JRE in LibreOffice 6.2.4.1
Comment 5 Alex Brooks 2019-05-14 14:45:53 UTC
This bug is no longer reproducible in

Version: 6.2.4.1 (x64)
Build ID: 170a9c04e0ad25cd937fc7a913bb06bf8c75c11d
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-GB
Calc: threaded

It appears to have been fixed in:

- 6.1.6
- 6.2.4
- 6.3.0

In bug 124503, through commit https://gerrit.libreoffice.org/plugins/gitiles/core/+/3d27b2fa9c5a03f78e5145377402f8a88e3da1be%5E%21

Technically, the solution used in that bug is *slightly* different, in that, rather than adding AdoptOpenJDK to the hardcoded supported list as requested in this bug, LibreOffice now assumes that every JVM not in the hardcoded list that reports that it is compatible with Java 6 at a minimum are usable as a JVM.  As a result, this bug is no longer reproducible in all supported and development branches.

Changing status to RESOLVED WORKSFORME.
Comment 6 pierre-yves samyn 2019-05-24 15:35:37 UTC
Hi

I confirm RESOLVED WORKSFORME on windows 7/64 with

Version: 6.3.0.0.alpha1+ (x64)
Build ID: f5b9590fc06811a9dff550c6998d1d1088507e23
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-05-23_22:33:02
Locale: fr-FR (fr_FR); UI-Language: en-US
Calc: threaded

Thank you
Best regards
Pierre-Yves
Comment 7 Kenneth 2019-06-03 22:57:58 UTC
Confirm problem.  OS and LO versions:
OpenSUSE Tumbleweed x86_64 current as of right now.
libreoffice-6.2.3.2-4.2.x86_64
libreoffice-base-6.2.3.2-4.2.x86_64
libreoffice-base-drivers-firebird-6.2.3.2-4.2.x86_64
libreoffice-branding-upstream-6.2.3.2-4.2.noarch
libreoffice-calc-6.2.3.2-4.2.x86_64
libreoffice-draw-6.2.3.2-4.2.x86_64
libreoffice-filters-optional-6.2.3.2-4.2.x86_64
libreoffice-icon-themes-6.2.3.2-4.2.noarch
libreoffice-impress-6.2.3.2-4.2.x86_64
libreoffice-l10n-en-6.2.3.2-4.2.noarch
libreoffice-mailmerge-6.2.3.2-4.2.x86_64
libreoffice-math-6.2.3.2-4.2.x86_64
libreoffice-pyuno-6.2.3.2-4.2.x86_64
libreoffice-qt5-6.2.3.2-4.2.x86_64
libreoffice-share-linker-1-4.6.noarch
libreoffice-writer-6.2.3.2-4.2.x86_64

java-1_8_0-openjdk-1.8.0.212-1.2.x86_64
java-1_8_0-openjdk-devel-1.8.0.212-1.2.x86_64
java-1_8_0-openjdk-headless-1.8.0.212-1.2.x86_64
java-1_8_0-openjdk-javadoc-1.8.0.212-1.2.noarch
Comment 8 Stephan Bergmann 2019-06-04 06:50:24 UTC
(In reply to Kenneth from comment #7)
> Confirm problem.  OS and LO versions:
> OpenSUSE Tumbleweed x86_64 current as of right now.
> libreoffice-6.2.3.2-4.2.x86_64
[...]

...which would be a further data point, in line with comment 2, suggesting that <https://gerrit.libreoffice.org/plugins/gitiles/core/+/273330a55d7cf457da6d7ba9829527a961c40bc0%5E%21> "Support AdoptOpenJDK", which should have fixed this on libreoffice-6-2 towards LO 6.2.1, does not work as intended.  (Which, again, "would be somewhat irrelevant as the fix for bug 124503 should indeed get this fixed, through a different internal approach," for LO 6.2.4.)

Or, Kenneth, I completely miss what you wanted to express with comment 7.