Download it now!
Bug 125049 - Request more standard (and useful) way to select anchor point for object align
Summary: Request more standard (and useful) way to select anchor point for object align
Status: RESOLVED DUPLICATE of bug 72118
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-30 15:54 UTC by Kurt
Modified: 2019-08-19 07:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt 2019-04-30 15:54:09 UTC
Description:
The use of the align in Draw is not consistent with the way align works in most other drawing programs, and the way it works now makes it impossible to use in many circumstances.



Steps to Reproduce:
.


Actual Results:
The way it works now is that it seems to align all objects to the selected part of their global bounding box.  So if you select three objects and then use "Align -> Top", all objects will move to the topmost edge of the topmost object.  For Align -> Center, it is particularly difficult because all objects in the selected will move the center of the bounding box.  So if you have several objects of different height that you want to align with the center of existing object, you can't.  All objects will move to their global bounding box center.

Expected Results:
The way most drawing programs (including InkScape and Corel Draw) handle this, is to make one object in the selection an anchor object.  In InkScape it is the last object selected in the group.  This means that you can always select which object to have all other objects reference against.

I can think of almost no instance where you would want to align the centers of objects and have them all move to the global bounding box center.  Align is almost always used to bring other objects in alignment with at least one other object in it's existing position.  Being able to select that object will be beneficial for all types of alignment and will bring LibreOffice Draw into agreement with best practices in drawing software.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Buovjaga 2019-08-17 14:37:11 UTC

*** This bug has been marked as a duplicate of bug 72118 ***