Bug Hunting Session
Bug 125061 - LibreOffice extension LanguageTool causes CPU usage to skyrocket
Summary: LibreOffice extension LanguageTool causes CPU usage to skyrocket
Status: RESOLVED DUPLICATE of bug 115757
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-01 13:08 UTC by Tim
Modified: 2019-05-28 14:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim 2019-05-01 13:08:32 UTC
Description:
CPU usage spikes to 110-130% (across 4 cores) when a large document (~260 pages, mainly text) is opened.

Steps to Reproduce:
1. Install LanguageTool extension
2. Open large file
3. Observe sustained spike in CPU usage and fan spin up
4. Close file
5. Observe CPU drop and fan spin down

Actual Results:
When LanguageTool is installed, opening a large document will send LibreOffice's CPU usage skyrocketing. After a few minutes (depending on the size of the
document), the usage does eventually drop back down below 5% again.

When uninstalled, opening a large document inhibits a short spike in CPU
usage, but quickly drops off.

Expected Results:
Small spike in CPU usage while opening, overall slight increase in CPU usage, total to remain >5%


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Tim 2019-05-01 13:12:42 UTC
Additional Info:
Version: 6.2.2.2
Build ID: 1:6.2.2-0ubuntu2
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: en-AU (en_AU.UTF-8); UI-Language: en-US
Calc: threaded

See also:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1825513
https://github.com/languagetool-org/languagetool/issues/1217?_pjax=%23js-repo-pjax-container
Comment 2 Buovjaga 2019-05-01 13:19:16 UTC
(In reply to Tim from comment #1)
> Additional Info:
> Version: 6.2.2.2
> Build ID: 1:6.2.2-0ubuntu2
> CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; 
> Locale: en-AU (en_AU.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> See also:
> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1825513
> https://github.com/languagetool-org/languagetool/issues/1217?_pjax=%23js-
> repo-pjax-container

So why open a new issue even though you saw bug 115757 already exists?
Comment 3 Alex Thurgood 2019-05-28 14:18:35 UTC

*** This bug has been marked as a duplicate of bug 115757 ***