Bug 125063 - Spreadsheet data is shown incorrectly during redaction
Summary: Spreadsheet data is shown incorrectly during redaction
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Muhammet Kara
URL:
Whiteboard: target:6.3.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-05-01 16:14 UTC by Aron Budea
Modified: 2019-05-07 21:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample ODS (9.12 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-05-01 16:14 UTC, Aron Budea
Details
PDF output from redaction with fresh master build (14.74 KB, application/pdf)
2019-05-01 16:16 UTC, Aron Budea
Details
PDF output from redaction with month old master build (24.19 KB, application/pdf)
2019-05-01 16:20 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2019-05-01 16:14:25 UTC
Created attachment 151114 [details]
Sample ODS

The attached spreadsheet contains just a diagonal line of "1" spanning over 3 pages.
Open Tools -> Redact.

=> The layout of the data on pages is incorrect. (for another fun result, check with just four "1"s, from A1 to D4)

This is a regression from the following commit. Adding Cc: to Muhammet Kara, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9683627f01d988be7958ee9a0311e20633598971
author		Muhammet Kara <muhammet.kara@collabora.com>	2019-03-29 12:18:12 +0300
committer	Muhammet Kara <muhammet.kara@collabora.com>	2019-03-29 11:11:58 +0100

Handle different page sizes for redaction
Comment 1 Aron Budea 2019-05-01 16:16:49 UTC
Created attachment 151115 [details]
PDF output from redaction with fresh master build

This one was done with a master build from yesterday, 6.3.0.0.alpha0+ (8f03bdee8225c619305ef210391dcc3b6c6fe284) / Windows 7.
Comment 2 Aron Budea 2019-05-01 16:20:54 UTC
Created attachment 151116 [details]
PDF output from redaction with month old master build

This build is from a 03-28, 6.3.0.0.alpha0+ (ed6a71eafa61bade50219d2ff6233a42ab6d1c17) / Windows 7.

Also note the tiny page number moving across the pages horizontally.
Comment 3 Muhammet Kara 2019-05-01 17:23:11 UTC
In fact, the content has the correct size, but the page has the incorrect size.

Seems like it is caused by a combination of depending on the content size while determining the page size, and Draw's inability to support a mix of different page sizes.
Comment 4 Muhammet Kara 2019-05-01 17:29:14 UTC
(In reply to Aron Budea from comment #2)
> Created attachment 151116 [details]
> PDF output from redaction with month old master build
> 
> This build is from a 03-28, 6.3.0.0.alpha0+
> (ed6a71eafa61bade50219d2ff6233a42ab6d1c17) / Windows 7.
> 
> Also note the tiny page number moving across the pages horizontally.

The tiny page number is another issue. Unrelated to this one.

Patch is on Gerrit: https://gerrit.libreoffice.org/#/c/71627/
Comment 5 Commit Notification 2019-05-02 17:30:00 UTC
Muhammet Kara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b743d446d8cccabcf3d002da652da0a8854ad883%5E%21

tdf#125063: Don't depend on content size for Page sizing

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Aron Budea 2019-05-07 21:24:11 UTC
Verified, thanks for the fix, Muhammet!

Version: 6.3.0.0.alpha0+ (x64)
Build ID: d6e8e41c22023bc15cc4c9659b33c1cc3d6edb75
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-06_01:12:47
Locale: en-US (en_US); UI-Language: en-US
Calc: CL