Bug 125076 - looking at recent files list we should see the path info
Summary: looking at recent files list we should see the path info
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Recent-Document-List GTK3
  Show dependency treegraph
 
Reported: 2019-05-02 08:46 UTC by peter josvai
Modified: 2019-08-15 21:27 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter josvai 2019-05-02 08:46:50 UTC
dear devs,

people offtentimes have documents with the same name in different directories...
also, people will offtentimes wonder where on earth a certain document is located... 

it would be great to see the path info when looking at the recent documents list.. (when the mouse goes over the given file)

removable media and/or inaccessible files could be indicated, too...

- - - thank you fore developing libreoffice - - -
Comment 1 Xisco Faulí 2019-05-02 10:19:47 UTC
My take: show it as tooltip... Let's the UX team decide
Comment 2 V Stuart Foote 2019-05-02 13:06:10 UTC
Can not confirm. On Windows build of 6.2.3.2 and master/6.3.0 both the Start Center -> Recent Files thumbnail views, and the per module File -> Recent Documents list *already* display full path in a tooltip on mouseover!

Already => WFM
Comment 3 Xisco Faulí 2019-05-02 13:27:10 UTC
oh, right!!
Closing as RESOLVED NOTABUG
Comment 4 Thomas Lendo 2019-05-05 12:55:57 UTC
I'm reopening this bug because I think the bug opener means the recent document list in the LibreOffice UI ('Open' toolbar command, etc.) and not in the Start Center.

I don't know if it's technically possible to have a tooltip on these recent document entries, but I'm definitively in favour of this idea after a latency time of some seconds to not disturb the normal mouse cursor path.
Comment 5 Xisco Faulí 2019-06-10 15:40:08 UTC
(In reply to Thomas Lendo from comment #4)
> I'm reopening this bug because I think the bug opener means the recent
> document list in the LibreOffice UI ('Open' toolbar command, etc.) and not
> in the Start Center.
> 
> I don't know if it's technically possible to have a tooltip on these recent
> document entries, but I'm definitively in favour of this idea after a
> latency time of some seconds to not disturb the normal mouse cursor path.

Moving to NEW then...
Comment 6 V Stuart Foote 2019-06-10 15:48:12 UTC
Huh? On Windows builds...

The MRU list (File -> Recent Documents) already includes the file extensions (if any) in its entry.

Also, its pop-up tooltip includes full path and file name there as well.

Pretty clear => WFM on Windows builds.

Folks seeing different on other builds?
Comment 7 Xisco Faulí 2019-06-10 16:17:10 UTC
oh, wait a second, it works in GTK2 and GEN but not in GTK3, thus, this is a GTK3 only bug...

@Caolán, I thought you could be interested in this issue...
Comment 8 Xisco Faulí 2019-06-10 16:17:50 UTC
Also reproduced in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 9 Caolán McNamara 2019-06-11 08:04:48 UTC
https://gitlab.gnome.org/GNOME/gtk/issues/785 no way to set tooltip on a menu item via GMenuModel
Comment 10 Cédric Bellegarde 2019-08-15 21:27:49 UTC
I resolved the issue in Lollypop by using a custom menu builder:

https://gitlab.gnome.org/World/lollypop/blob/master/lollypop/widgets_menu.py

Allows me to add more custom attributes.