Bug 125082 - Format / Paragraph Insert with page number: Not saved if set to 0
Summary: Format / Paragraph Insert with page number: Not saved if set to 0
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fields-Page-Number
  Show dependency treegraph
 
Reported: 2019-05-02 12:50 UTC by brodders
Modified: 2019-05-03 15:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brodders 2019-05-02 12:50:42 UTC
There is a need to set Page Number to zero when using Left Page / Right Page page layout.

Traditionally, the Right page of a document starts on Page 1. The Left page cannot be numbered as 1; it must be even.

Thus entering a new section with Left/Right pages defined means that, to get Page 1 as the right-hand page, the left page must be numbered as the prior even number i.e. zero.

This may be done at a Paragraph level:

select some text on the left page
Format / Paragraph / Text Flow / Breaks Insert. Tick Page Number and set to zero.

This succeeds in making the left page 0 and the right page is Page 1.

However, there seems to be Save validation prohibiting saving page numbers below 1; the page number setting is discarded.

Editing the data within the .odt file to zero will open the doc with Page Number of 0 on the left as wanted, so this is a Save validation check.

As is, on each reopening of the document the left page number set as zero is found discarded and resetting the page to be zero must be repeated.

This was performed in a Master file, but is likely for other Writer file types.


Can validation rule be removed or zero allowed?

Thanks
Comment 1 Dieter 2019-05-02 19:05:01 UTC
I can't see a use case for having a page number 0. I never saw this. Page counting always starts with 1 or the Roman I. Of course there might be some pages before. But they never have the page number 0. So I would say NOTABUG.
Comment 2 brodders 2019-05-02 20:08:53 UTC
Left-Right pages are pairs. Yet, the traditional first page of a document is the right-hand page. What number then is the (mandatory) Left page of a Left-Right pair, if the Right is page 1? :)
Comment 3 Dieter 2019-05-03 09:17:22 UTC
Although I  don't see the use, case, I found, that you have the possibility to set pagenumber to 0.

1. Insert Pagenumber
2. Mark pagenumber => Context menu: Edit fields
3. Set Offset to -1

=> RESOLVED WORKSFORME
Comment 4 brodders 2019-05-03 15:00:54 UTC
OK, that works - have just tried it and it saves OK.


But this is non-obvious; a 3-step process is needed:

1. highlight phrase on Left page; use Paragraph / Text flow / Insert Break page number 1
2. adjust page number field on Left page to offset by -1
3. adjust page number field on Right page to offset by -1 (these are independent)

And this is why LO is sometimes difficult to use.

We are now not fixing a UI situation, as there is a workaround (even if not obvious) rather than fixing the thing <which is Step 1> so it works in an obvious manner.

Rinse and repeat over years; such cruft builds ===> user is confused as they are supposed to know dozens of non-obvious workarounds as the thing in front of them does not do what it says on the tin.

And the use-case:

Writing a thesis. This has many sections all with different layout; the main body (with Left-Right pages) comes after front page / contents / glossary etc etc. i.e. several other format sections before the Left Right pairs start.

Thanks agn!
Comment 5 Dieter 2019-05-03 15:08:47 UTC
(In reply to brodders from comment #4)
> Writing a thesis.

I did it as well. And I learnt a lot about LO ;-)