Bug 125092 - FORMATTING Cells often displayed with wrong font
Summary: FORMATTING Cells often displayed with wrong font
Status: RESOLVED DUPLICATE of bug 125054
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-02 21:19 UTC by Stefan_Lange_KA@T-Online.de
Modified: 2019-11-08 10:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
zip fole with test document and 2 screenshots (from LO 6.2.3 and from LO 6.3.0) (339.42 KB, application/x-zip-compressed)
2019-05-02 21:19 UTC, Stefan_Lange_KA@T-Online.de
Details
Screenshot made with last daily build of LO 6.3 (127.28 KB, image/png)
2019-05-03 22:59 UTC, Stefan_Lange_KA@T-Online.de
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan_Lange_KA@T-Online.de 2019-05-02 21:19:00 UTC
Created attachment 151144 [details]
zip fole with test document and 2 screenshots (from LO 6.2.3 and from LO 6.3.0)

Calc in LO 6.3.0 often uses wrong font to display the cells.
The problem seems not to exist when the document is opened read-only!!!

To reproduce the problem open the document "Bildkommentare Test Bahnschrift condensed LO 6.3.0.ods" from the attached zip file with LO 6.2.3, check it and close it and after this do the same with LO 6.3.0.

- In LO 6.2.3 all cells are formatted correctly, means the cells are formatted with font "Bahnschrift condensed". --> Screenshot

- In LO 6.3.0 some cells are displayed correctly, but many cells are formatted with a different font (seems Liberation Serif). --> Screenshot
The behavior can be reproduced. It is not by chance which cells are properly formatted and which are formatted incorrectly, but I haven't found a system until now.

further problem in LO 6.3.0:
- when a cell is selected the font in the Font List is shown correctly (e.g. as "Bahnschrift condensed")!
- When F2 is pressed or all the cell content is selected font is shown as "Liberation Serif". When an other font is selected in the Font list the cell content will be formatted with the selected font - but only until the cell is left. When the focus goes to an other cell, then the cell is re-formatted with the previous used font.
Comment 1 Durgapriyanka 2019-05-03 22:25:32 UTC
Thank you for reporting the bug. Unfortunately, I cannot reproduce this bug in both

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4 

&

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 2 Stefan_Lange_KA@T-Online.de 2019-05-03 22:59:41 UTC
Created attachment 151170 [details]
Screenshot made with last daily build of LO 6.3

The build 2019-01-30_06:57:04 is relatively old and I have found the problem with newer builds and once again tested with the build from yesterday (installed with libo-master64~2019-05-02_22.43.22_LibreOfficeDev_6.3.0.0.alpha0_Win_x64.msi) with the same result, see attached new screenshot. 
As regession I will try to test with an older builds (if I find them - in "Daily" I find only young builds) when the problem occurs first.
Comment 3 Stefan_Lange_KA@T-Online.de 2019-05-04 07:35:32 UTC
Unfortunately I haven't saved on my computer installation files for daliy LOdev 6.3.0 builds older than end of April.
Is there a way to download them for regresion test from document foundation or libreoffice servers?
I have also tested again with daily Builds LOdev 6.2.4.0.0 2019-05-03_10.18.01 and LOdev 6.3.0.0alpha0 2019-05-03_23.08.41: The problem doesn't exist in LOdev 6.2.4 but only in LOdev 6.3.0.
Comment 4 Xisco Faulí 2019-05-07 11:48:36 UTC
Thanks for reporting this issue.
Seems like a dupe of bug 125054

*** This bug has been marked as a duplicate of bug 125054 ***
Comment 5 Kevin Suo 2019-11-07 23:44:22 UTC
I my opinion this is a diplicate of bug 126248. I guess this issue os not fixed yet, but rather still exists on master, is it? @Stefan_Lange_KA
Comment 6 Stefan_Lange_KA@T-Online.de 2019-11-08 10:34:17 UTC
I guess I can't help here. For me the described problem was solved after the bug was declared as duplicate of bug 125054 and this bug was fixed + verified in 05/2019.
At the moment, I have no way to reproduce the problem of bug 126248. First I must become familiar with things to do to reproduce the bug.